You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
34 lines
1.1 KiB
34 lines
1.1 KiB
From 5f72a51d7eb23cd18eb07639757d4dcea2e6a2ab Mon Sep 17 00:00:00 2001
|
|
From: Igor Raits <i.gnatenko.brain@gmail.com>
|
|
Date: Fri, 22 May 2020 12:28:05 +0200
|
|
Subject: [PATCH] Remove usage of jemallocator
|
|
|
|
It is PITA to package it in Fedora, so we will have to have fd a bit
|
|
slower for now.
|
|
|
|
Signed-off-by: Igor Raits <i.gnatenko.brain@gmail.com>
|
|
---
|
|
src/main.rs | 6 ------
|
|
1 file changed, 6 deletions(-)
|
|
|
|
diff --git a/src/main.rs b/src/main.rs
|
|
index 6ffa277..aee72ce 100644
|
|
--- a/src/main.rs
|
|
+++ b/src/main.rs
|
|
@@ -32,12 +32,6 @@ use crate::filter::{SizeFilter, TimeFilter};
|
|
use crate::options::Options;
|
|
use crate::regex_helper::pattern_has_uppercase_char;
|
|
|
|
-// We use jemalloc for performance reasons, see https://github.com/sharkdp/fd/pull/481
|
|
-// FIXME: re-enable jemalloc on macOS, see comment in Cargo.toml file for more infos
|
|
-#[cfg(all(not(windows), not(target_os = "macos"), not(target_env = "musl")))]
|
|
-#[global_allocator]
|
|
-static ALLOC: jemallocator::Jemalloc = jemallocator::Jemalloc;
|
|
-
|
|
fn run() -> Result<ExitCode> {
|
|
let matches = app::build_app().get_matches_from(env::args_os());
|
|
|
|
--
|
|
2.26.2
|
|
|