parent
29abcc6eb1
commit
0108c147e3
@ -0,0 +1 @@
|
||||
/fast-srgb8-1.0.0.crate
|
@ -0,0 +1,11 @@
|
||||
--- fast-srgb8-1.0.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ fast-srgb8-1.0.0/Cargo.toml 2023-11-29T12:15:51.959242+00:00
|
||||
@@ -21,7 +21,7 @@
|
||||
readme = "README.md"
|
||||
keywords = ["srgb", "simd", "color", "rgb", "convert"]
|
||||
categories = ["graphics", "no-std", "mathematics", "rendering"]
|
||||
-license = "MIT OR Apache-2.0 OR CC0-1.0"
|
||||
+license = "MIT OR Apache-2.0"
|
||||
repository = "https://github.com/thomcc/fast-srgb8"
|
||||
|
||||
[dependencies]
|
@ -0,0 +1,73 @@
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate fast-srgb8
|
||||
|
||||
Name: rust-fast-srgb8
|
||||
Version: 1.0.0
|
||||
Release: %autorelease
|
||||
Summary: Very fast conversions between linear float and 8-bit sRGB
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/fast-srgb8
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * remove non-acceptable "CC0-1.0" license alternative from crate metadata
|
||||
Patch: fast-srgb8-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Very fast conversions between linear float and 8-bit sRGB (with no_std
|
||||
support).}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue