Initial import (event-listener 3 compat package)

epel9 imports/e9/rust-event-listener3-3.1.0-1.el9
Fabio Valentini 1 year ago
parent 1396e2875e
commit f56582cf74
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -0,0 +1 @@
/event-listener-3.1.0.crate

@ -1,3 +0,0 @@
# rust-event-listener3
The rust-event-listener3 package

@ -0,0 +1,8 @@
--- event-listener-3.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ event-listener-3.1.0/Cargo.toml 2023-12-31T17:58:58.710799+00:00
@@ -84,5 +84,3 @@
version = "2.0.0"
optional = true
-[target."cfg(target_family = \"wasm\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3"

@ -0,0 +1,14 @@
--- event-listener-3.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ event-listener-3.1.0/Cargo.toml 2023-12-31T17:59:05.103822+00:00
@@ -58,11 +58,6 @@
default-features = false
package = "portable-atomic"
-[dev-dependencies.criterion]
-version = "0.4.0"
-features = ["cargo_bench_support"]
-default-features = false
-
[dev-dependencies.futures-lite]
version = "2.0.0"

@ -0,0 +1,135 @@
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate event-listener
Name: rust-event-listener3
Version: 3.1.0
Release: %autorelease
Summary: Notify async tasks or threads
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/event-listener
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: event-listener-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
Patch: event-listener-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Notify async tasks or threads.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parking-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parking-devel %{_description}
This package contains library source intended for building other packages which
use the "parking" feature of the "%{crate}" crate.
%files -n %{name}+parking-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+portable-atomic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+portable-atomic-devel %{_description}
This package contains library source intended for building other packages which
use the "portable-atomic" feature of the "%{crate}" crate.
%files -n %{name}+portable-atomic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+portable-atomic-util-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+portable-atomic-util-devel %{_description}
This package contains library source intended for building other packages which
use the "portable-atomic-util" feature of the "%{crate}" crate.
%files -n %{name}+portable-atomic-util-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+portable_atomic_crate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+portable_atomic_crate-devel %{_description}
This package contains library source intended for building other packages which
use the "portable_atomic_crate" feature of the "%{crate}" crate.
%files -n %{name}+portable_atomic_crate-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (event-listener-3.1.0.crate) = e341cb624bfbbf0c58ae177e6a0bf462a7bbccdfff839f04051b7bc6338c6c504f3c6593e69f5cdad3592202e11979fa0b9986794272856b746ffdcfc7fb3154
Loading…
Cancel
Save