import rust-event-listener3-3.1.0-1.el9

i9ce changed/i9ce/rust-event-listener3-3.1.0-1.el9
Arkady L. Shane 1 year ago
commit d1a80ebe53
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

@ -0,0 +1,8 @@
--- event-listener-3.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ event-listener-3.1.0/Cargo.toml 2023-12-31T17:58:58.710799+00:00
@@ -84,5 +84,3 @@
version = "2.0.0"
optional = true
-[target."cfg(target_family = \"wasm\")".dev-dependencies.wasm-bindgen-test]
-version = "0.3"

@ -0,0 +1,14 @@
--- event-listener-3.1.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ event-listener-3.1.0/Cargo.toml 2023-12-31T17:59:05.103822+00:00
@@ -58,11 +58,6 @@
default-features = false
package = "portable-atomic"
-[dev-dependencies.criterion]
-version = "0.4.0"
-features = ["cargo_bench_support"]
-default-features = false
-
[dev-dependencies.futures-lite]
version = "2.0.0"

@ -0,0 +1,149 @@
## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate event-listener
Name: rust-event-listener3
Version: 3.1.0
Release: %autorelease
Summary: Notify async tasks or threads
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/event-listener
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: event-listener-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop unused, benchmark-only criterion dev-dependency
Patch: event-listener-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Notify async tasks or threads.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+parking-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+parking-devel %{_description}
This package contains library source intended for building other packages which
use the "parking" feature of the "%{crate}" crate.
%files -n %{name}+parking-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+portable-atomic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+portable-atomic-devel %{_description}
This package contains library source intended for building other packages which
use the "portable-atomic" feature of the "%{crate}" crate.
%files -n %{name}+portable-atomic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+portable-atomic-util-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+portable-atomic-util-devel %{_description}
This package contains library source intended for building other packages which
use the "portable-atomic-util" feature of the "%{crate}" crate.
%files -n %{name}+portable-atomic-util-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+portable_atomic_crate-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+portable_atomic_crate-devel %{_description}
This package contains library source intended for building other packages which
use the "portable_atomic_crate" feature of the "%{crate}" crate.
%files -n %{name}+portable_atomic_crate-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 3.1.0-1
- Rebuilt for MSVSphere 9.3
* Tue Jan 02 2024 Fabio Valentini <decathorpe@gmail.com> - 3.1.0-1
- Initial import (event-listener 3 compat package)
Loading…
Cancel
Save