i9ce
changed/i9ce/rust-event-listener-strategy-0.4.0-1.el9
commit
be2b5729bc
Binary file not shown.
@ -0,0 +1,8 @@
|
||||
--- event-listener-strategy-0.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ event-listener-strategy-0.4.0/Cargo.toml 2024-01-02T13:48:47.020742+00:00
|
||||
@@ -53,5 +53,3 @@
|
||||
default = ["std"]
|
||||
std = ["event-listener/std"]
|
||||
|
||||
-[target."cfg(target_family = \"wasm\")".dev-dependencies.wasm-bindgen-test]
|
||||
-version = "0.3.37"
|
@ -0,0 +1,101 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate event-listener-strategy
|
||||
|
||||
Name: rust-event-listener-strategy
|
||||
Version: 0.4.0
|
||||
Release: %autorelease
|
||||
Summary: Block or poll on event_listener easily
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/event-listener-strategy
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: event-listener-strategy-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Block or poll on event_listener easily.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.0-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Tue Jan 02 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.0-1
|
||||
- Update to version 0.4.0; Fixes RHBZ#2252078
|
||||
|
||||
* Thu Nov 16 2023 Fabio Valentini <decathorpe@gmail.com> - 0.3.0-1
|
||||
- Initial import (#2249716)
|
Loading…
Reference in new issue