Update to version 0.5.3; Fixes RHBZ#2329639

epel10 imports/epel10/rust-event-listener-strategy-0.5.3-1.el10
Fabio Valentini 3 months ago
parent cdd6493a90
commit a823e1dd64
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -2,3 +2,4 @@
/event-listener-strategy-0.4.0.crate
/event-listener-strategy-0.5.0.crate
/event-listener-strategy-0.5.2.crate
/event-listener-strategy-0.5.3.crate

@ -1,8 +1,14 @@
--- event-listener-strategy-0.5.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ event-listener-strategy-0.5.2/Cargo.toml 2024-05-08T18:14:29.083100+00:00
@@ -53,5 +53,3 @@
default = ["std"]
--- event-listener-strategy-0.5.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ event-listener-strategy-0.5.3/Cargo.toml 2024-12-01T20:22:36.947505+00:00
@@ -67,10 +67,8 @@
loom = ["event-listener/loom"]
std = ["event-listener/std"]
-[target."cfg(target_family = \"wasm\")".dev-dependencies.wasm-bindgen-test]
-[target.'cfg(target_family = "wasm")'.dev-dependencies.wasm-bindgen-test]
-version = "0.3.37"
-
[lints.rust.unexpected_cfgs]
level = "warn"
priority = 0
check-cfg = ["cfg(wasm_bindgen_unstable_test_coverage)"]
+

@ -0,0 +1,10 @@
--- event-listener-strategy-0.5.3/Cargo.toml 1970-01-01T00:00:01+00:00
+++ event-listener-strategy-0.5.3/Cargo.toml 2024-12-01T20:22:40.167522+00:00
@@ -64,7 +64,6 @@
[features]
default = ["std"]
-loom = ["event-listener/loom"]
std = ["event-listener/std"]
[lints.rust.unexpected_cfgs]

@ -1,11 +1,11 @@
# Generated by rust2rpm 26
%bcond_without check
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate event-listener-strategy
Name: rust-event-listener-strategy
Version: 0.5.2
Version: 0.5.3
Release: %autorelease
Summary: Block or poll on event_listener easily
@ -14,6 +14,9 @@ URL: https://crates.io/crates/event-listener-strategy
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: event-listener-strategy-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop feature for unsupported loom permutation testing framework
Patch: event-listener-strategy-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24

@ -0,0 +1,5 @@
[package]
cargo-toml-patch-comments = [
"drop feature for unsupported loom permutation testing framework",
]

@ -1 +1 @@
SHA512 (event-listener-strategy-0.5.2.crate) = 7b3759d07c7936b53351172e38623658cbe642f079426c99e7f9187ba1d7f8cbbe7530c056cc760909cda4e70281a50577caa41426164b4c8d6c3f4cbddb2626
SHA512 (event-listener-strategy-0.5.3.crate) = f1a14f69afb9765a317b3d7bda505a28f050a7594d6b07e5263d635b806d494ab41c456dcf38ca924ecc0595be0f77e32ffe239107fce1cc5b71ee7249419f5a

Loading…
Cancel
Save