Initial import (#2249716)
parent
7337d8e3e7
commit
565d793127
@ -0,0 +1 @@
|
||||
/event-listener-strategy-0.3.0.crate
|
@ -1,3 +0,0 @@
|
||||
# rust-event-listener-strategy
|
||||
|
||||
The rust-event-listener-strategy package
|
@ -0,0 +1,8 @@
|
||||
--- event-listener-strategy-0.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ event-listener-strategy-0.3.0/Cargo.toml 2023-11-14T23:14:19.210717+00:00
|
||||
@@ -53,5 +53,3 @@
|
||||
default = ["std"]
|
||||
std = ["event-listener/std"]
|
||||
|
||||
-[target."cfg(target_family = \"wasm\")".dev-dependencies.wasm-bindgen-test]
|
||||
-version = "0.3.37"
|
@ -0,0 +1,84 @@
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate event-listener-strategy
|
||||
|
||||
Name: rust-event-listener-strategy
|
||||
Version: 0.3.0
|
||||
Release: %autorelease
|
||||
Summary: Block or poll on event_listener easily
|
||||
|
||||
License: Apache-2.0 OR MIT
|
||||
URL: https://crates.io/crates/event-listener-strategy
|
||||
Source: %{crates_source}
|
||||
# Automatically generated patch to strip dependencies and normalize metadata
|
||||
Patch: event-listener-strategy-fix-metadata-auto.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Block or poll on event_listener easily.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+std-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+std-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "std" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+std-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue