You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
199 lines
6.1 KiB
199 lines
6.1 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.3)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 26
|
|
# * files required by tests are not included in published crates
|
|
%bcond_with check
|
|
%global debug_package %{nil}
|
|
|
|
# prevent executables from being installed
|
|
%global cargo_install_bin 0
|
|
|
|
%global crate escargot
|
|
|
|
Name: rust-escargot
|
|
Version: 0.5.13
|
|
Release: %autorelease
|
|
Summary: Cargo API written in Paris
|
|
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/escargot
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 26
|
|
|
|
%global _description %{expand:
|
|
Cargo API written in Paris.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+cargo_unstable-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+cargo_unstable-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "cargo_unstable" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+cargo_unstable-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+print-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+print-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "print" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+print-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+strict_unstable-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+strict_unstable-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "strict_unstable" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+strict_unstable-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+test_unstable-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+test_unstable-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "test_unstable" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+test_unstable-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.5.13-1
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
## START: Generated by rpmautospec
|
|
* Wed Oct 30 2024 Fabio Valentini <decathorpe@gmail.com> - 0.5.13-1
|
|
- Update to version 0.5.13; Fixes RHBZ#2322534
|
|
|
|
* Fri Jul 26 2024 Fabio Valentini <decathorpe@gmail.com> - 0.5.12-1
|
|
- Update to version 0.5.12; Fixes RHBZ#2299870
|
|
|
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.11-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Mon Jun 10 2024 Fabio Valentini <decathorpe@gmail.com> - 0.5.11-1
|
|
- Update to version 0.5.11; Fixes RHBZ#2290776
|
|
|
|
* Thu Apr 25 2024 Fabio Valentini <decathorpe@gmail.com> - 0.5.10-1
|
|
- Update to version 0.5.10; Fixes RHBZ#2265869
|
|
|
|
* Wed Feb 14 2024 Fabio Valentini <decathorpe@gmail.com> - 0.5.9-1
|
|
- Update to version 0.5.9; Fixes RHBZ#2263538
|
|
|
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.8-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Wed Aug 02 2023 Fabio Valentini <decathorpe@gmail.com> - 0.5.8-1
|
|
- Update to version 0.5.8; Fixes RHBZ#2228536
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.7-5
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.7-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.7-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.7-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Wed Dec 15 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.7-1
|
|
- Update to version 0.5.7; Fixes RHBZ#2032990
|
|
|
|
* Tue Nov 09 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.6-1
|
|
- Update to version 0.5.6; Fixes RHBZ#2021323
|
|
|
|
* Tue Jul 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.2-2
|
|
- Second attempt - Rebuilt for
|
|
https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
|
|
|
* Sun Mar 28 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.2-1
|
|
- Update to version 0.5.2.
|
|
- Fixes RHBZ#1943822
|
|
|
|
* Mon Feb 08 2021 Fabio Valentini <decathorpe@gmail.com> - 0.5.1-1
|
|
- Update to version 0.5.1.
|
|
- Fixes RHBZ#1923784
|
|
|
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
|
|
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
|
|
|
* Wed Mar 04 13:44:47 EET 2020 Artem Polishchuk <ego.cordatus@gmail.com> - 0.5.0-1
|
|
- Initial package
|
|
|
|
## END: Generated by rpmautospec
|