parent
de9969b7ea
commit
2297af678a
@ -0,0 +1 @@
|
||||
/encoding-0.2.33.crate
|
@ -0,0 +1,26 @@
|
||||
--- encoding-0.2.33/Cargo.toml 2016-08-28T18:53:46+02:00
|
||||
+++ encoding-0.2.33/Cargo.toml 2017-11-13T18:16:28.129620+01:00
|
||||
@@ -24,23 +24,18 @@
|
||||
|
||||
[dependencies.encoding-index-singlebyte]
|
||||
version = "~1.20141219.5"
|
||||
-path = "src/index/singlebyte"
|
||||
|
||||
[dependencies.encoding-index-korean]
|
||||
version = "~1.20141219.5"
|
||||
-path = "src/index/korean"
|
||||
|
||||
[dependencies.encoding-index-japanese]
|
||||
version = "~1.20141219.5"
|
||||
-path = "src/index/japanese"
|
||||
|
||||
[dependencies.encoding-index-simpchinese]
|
||||
version = "~1.20141219.5"
|
||||
-path = "src/index/simpchinese"
|
||||
|
||||
[dependencies.encoding-index-tradchinese]
|
||||
version = "~1.20141219.5"
|
||||
-path = "src/index/tradchinese"
|
||||
|
||||
[dev-dependencies]
|
||||
getopts = "0.2" # for examples
|
@ -0,0 +1,70 @@
|
||||
# Generated by rust2rpm
|
||||
# Tests require nightly compiler
|
||||
%bcond_with check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate encoding
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.33
|
||||
Release: 1%{?dist}
|
||||
Summary: Character encoding support for Rust
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/encoding
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No paths
|
||||
Patch0: encoding-0.2.33-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(encoding-index-japanese) >= 1.20141219.5 with crate(encoding-index-japanese) < 1.20141220.0)
|
||||
BuildRequires: (crate(encoding-index-korean) >= 1.20141219.5 with crate(encoding-index-korean) < 1.20141220.0)
|
||||
BuildRequires: (crate(encoding-index-simpchinese) >= 1.20141219.5 with crate(encoding-index-simpchinese) < 1.20141220.0)
|
||||
BuildRequires: (crate(encoding-index-singlebyte) >= 1.20141219.5 with crate(encoding-index-singlebyte) < 1.20141220.0)
|
||||
BuildRequires: (crate(encoding-index-tradchinese) >= 1.20141219.5 with crate(encoding-index-tradchinese) < 1.20141220.0)
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(getopts) >= 0.2.0 with crate(getopts) < 0.3.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Character encoding support for Rust.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license LICENSE.txt
|
||||
%doc README.md AUTHORS.txt
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
%exclude %{cargo_registry}/%{crate}-%{version}/{Makefile,src/index}
|
||||
|
||||
%changelog
|
||||
* Mon Nov 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.2.33-1
|
||||
- Initial package
|
Loading…
Reference in new issue