You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-elliptic-curve/rust-elliptic-curve.spec

277 lines
7.3 KiB

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate elliptic-curve
Name: rust-elliptic-curve
Version: 0.13.8
Release: %autorelease
Summary: General purpose Elliptic Curve Cryptography
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/elliptic-curve
Source: %{crates_source}
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
General purpose Elliptic Curve Cryptography (ECC) support, including
types and traits for representing various elliptic curve forms, scalars,
points, and public/secret keys composed thereof.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arithmetic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arithmetic-devel %{_description}
This package contains library source intended for building other packages which
use the "arithmetic" feature of the "%{crate}" crate.
%files -n %{name}+arithmetic-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+bits-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+bits-devel %{_description}
This package contains library source intended for building other packages which
use the "bits" feature of the "%{crate}" crate.
%files -n %{name}+bits-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dev-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dev-devel %{_description}
This package contains library source intended for building other packages which
use the "dev" feature of the "%{crate}" crate.
%files -n %{name}+dev-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+digest-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+digest-devel %{_description}
This package contains library source intended for building other packages which
use the "digest" feature of the "%{crate}" crate.
%files -n %{name}+digest-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ecdh-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ecdh-devel %{_description}
This package contains library source intended for building other packages which
use the "ecdh" feature of the "%{crate}" crate.
%files -n %{name}+ecdh-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ff-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ff-devel %{_description}
This package contains library source intended for building other packages which
use the "ff" feature of the "%{crate}" crate.
%files -n %{name}+ff-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+group-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+group-devel %{_description}
This package contains library source intended for building other packages which
use the "group" feature of the "%{crate}" crate.
%files -n %{name}+group-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hash2curve-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hash2curve-devel %{_description}
This package contains library source intended for building other packages which
use the "hash2curve" feature of the "%{crate}" crate.
%files -n %{name}+hash2curve-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hazmat-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hazmat-devel %{_description}
This package contains library source intended for building other packages which
use the "hazmat" feature of the "%{crate}" crate.
%files -n %{name}+hazmat-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+jwk-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+jwk-devel %{_description}
This package contains library source intended for building other packages which
use the "jwk" feature of the "%{crate}" crate.
%files -n %{name}+jwk-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pem-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pem-devel %{_description}
This package contains library source intended for building other packages which
use the "pem" feature of the "%{crate}" crate.
%files -n %{name}+pem-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pkcs8-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pkcs8-devel %{_description}
This package contains library source intended for building other packages which
use the "pkcs8" feature of the "%{crate}" crate.
%files -n %{name}+pkcs8-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sec1-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sec1-devel %{_description}
This package contains library source intended for building other packages which
use the "sec1" feature of the "%{crate}" crate.
%files -n %{name}+sec1-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+voprf-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+voprf-devel %{_description}
This package contains library source intended for building other packages which
use the "voprf" feature of the "%{crate}" crate.
%files -n %{name}+voprf-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog