You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-digest/rust-digest.spec

204 lines
5.2 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate digest
Name: rust-digest
Version: 0.10.7
Release: %autorelease
Summary: Traits for cryptographic hash functions and message authentication codes
License: MIT OR Apache-2.0
URL: https://crates.io/crates/digest
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Traits for cryptographic hash functions and message authentication
codes.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+blobby-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+blobby-devel %{_description}
This package contains library source intended for building other packages which
use the "blobby" feature of the "%{crate}" crate.
%files -n %{name}+blobby-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+block-buffer-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+block-buffer-devel %{_description}
This package contains library source intended for building other packages which
use the "block-buffer" feature of the "%{crate}" crate.
%files -n %{name}+block-buffer-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+const-oid-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+const-oid-devel %{_description}
This package contains library source intended for building other packages which
use the "const-oid" feature of the "%{crate}" crate.
%files -n %{name}+const-oid-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+core-api-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+core-api-devel %{_description}
This package contains library source intended for building other packages which
use the "core-api" feature of the "%{crate}" crate.
%files -n %{name}+core-api-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dev-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dev-devel %{_description}
This package contains library source intended for building other packages which
use the "dev" feature of the "%{crate}" crate.
%files -n %{name}+dev-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+mac-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mac-devel %{_description}
This package contains library source intended for building other packages which
use the "mac" feature of the "%{crate}" crate.
%files -n %{name}+mac-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+oid-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+oid-devel %{_description}
This package contains library source intended for building other packages which
use the "oid" feature of the "%{crate}" crate.
%files -n %{name}+oid-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand_core-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand_core-devel %{_description}
This package contains library source intended for building other packages which
use the "rand_core" feature of the "%{crate}" crate.
%files -n %{name}+rand_core-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+subtle-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+subtle-devel %{_description}
This package contains library source intended for building other packages which
use the "subtle" feature of the "%{crate}" crate.
%files -n %{name}+subtle-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog