You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-difftastic/rust-difftastic.spec

77 lines
1.8 KiB

# Generated by rust2rpm 25
%bcond_without check
%global crate difftastic
Name: rust-difftastic
Version: 0.53.1
Release: %autorelease
Summary: Structural diff that understands syntax
License: MIT
URL: https://crates.io/crates/difftastic
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * unpin libmimalloc-sys
# * remove upper bound on:
# * aho-corasick
# * assert_cmd
# * ignore
# * is-terminal
# * memchr
# * predicates
# * regex
Patch: difftastic-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A structural diff that understands syntax.}
%description %{_description}
%package -n %{crate}
Summary: %{summary}
# (MIT OR Apache-2.0) AND Unicode-DFS-2016
# Apache-2.0 OR BSL-1.0
# Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# MIT
# MIT AND Unicode-DFS-2016 AND BSD-2-Clause AND BSD-3-Clause AND LicenseRef-Fedora-Public-Domain
# MIT OR Apache-2.0
# Unlicense OR MIT
# Zlib
License: ((MIT OR Apache-2.0) AND Unicode-DFS-2016) AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND MIT AND (MIT AND Unicode-DFS-2016 AND BSD-2-Clause AND BSD-3-Clause AND LicenseRef-Fedora-Public-Domain) AND (Unlicense OR MIT) AND Zlib
# LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description}
%files -n %{crate}
%license LICENSE
%license LICENSE.dependencies
%doc README.md
%{_bindir}/difft
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%{cargo_license_summary}
%{cargo_license} > LICENSE.dependencies
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog