commit
d93ab757af
Binary file not shown.
@ -0,0 +1,64 @@
|
||||
--- difftastic-0.53.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ difftastic-0.53.1/Cargo.toml 2023-12-05T20:07:48.661991+00:00
|
||||
@@ -54,7 +54,7 @@
|
||||
path = "src/main.rs"
|
||||
|
||||
[dependencies.aho-corasick]
|
||||
-version = ">= 1.0, < 1.1.0"
|
||||
+version = "1"
|
||||
|
||||
[dependencies.bumpalo]
|
||||
version = "3.11.1"
|
||||
@@ -84,10 +84,10 @@
|
||||
version = "2.1.3"
|
||||
|
||||
[dependencies.ignore]
|
||||
-version = ">= 0.4, < 0.4.19"
|
||||
+version = "0.4"
|
||||
|
||||
[dependencies.is-terminal]
|
||||
-version = ">= 0.4, < 0.4.8"
|
||||
+version = "0.4"
|
||||
|
||||
[dependencies.itertools]
|
||||
version = "0.11.0"
|
||||
@@ -99,7 +99,7 @@
|
||||
version = "0.2.108"
|
||||
|
||||
[dependencies.libmimalloc-sys]
|
||||
-version = "=0.1.24"
|
||||
+version = "0.1.24"
|
||||
|
||||
[dependencies.line-numbers]
|
||||
version = "0.3.0"
|
||||
@@ -108,7 +108,7 @@
|
||||
version = "0.4.14"
|
||||
|
||||
[dependencies.memchr]
|
||||
-version = ">= 2, < 2.6"
|
||||
+version = "2"
|
||||
|
||||
[dependencies.mimalloc]
|
||||
version = "0.1.28"
|
||||
@@ -127,7 +127,7 @@
|
||||
version = "1.7.0"
|
||||
|
||||
[dependencies.regex]
|
||||
-version = ">= 1.9, < 1.9.5"
|
||||
+version = "1.9"
|
||||
|
||||
[dependencies.rustc-hash]
|
||||
version = "1.1.0"
|
||||
@@ -162,10 +162,10 @@
|
||||
version = "0.1.2"
|
||||
|
||||
[dev-dependencies.assert_cmd]
|
||||
-version = ">= 2, <= 2.0.5"
|
||||
+version = "2"
|
||||
|
||||
[dev-dependencies.predicates]
|
||||
-version = ">= 2, <= 2.1.1"
|
||||
+version = "2"
|
||||
|
||||
[dev-dependencies.pretty_assertions]
|
||||
version = "1.3.0"
|
@ -0,0 +1,128 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.3.5)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 1;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 25
|
||||
%bcond_without check
|
||||
|
||||
%global crate difftastic
|
||||
|
||||
Name: rust-difftastic
|
||||
Version: 0.53.1
|
||||
Release: %autorelease
|
||||
Summary: Structural diff that understands syntax
|
||||
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/difftastic
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * unpin libmimalloc-sys
|
||||
# * remove upper bound on:
|
||||
# * aho-corasick
|
||||
# * assert_cmd
|
||||
# * ignore
|
||||
# * is-terminal
|
||||
# * memchr
|
||||
# * predicates
|
||||
# * regex
|
||||
Patch: difftastic-fix-metadata.diff
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
A structural diff that understands syntax.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package -n %{crate}
|
||||
Summary: %{summary}
|
||||
# (MIT OR Apache-2.0) AND Unicode-DFS-2016
|
||||
# Apache-2.0 OR BSL-1.0
|
||||
# Apache-2.0 OR MIT
|
||||
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
|
||||
# MIT
|
||||
# MIT AND Unicode-DFS-2016 AND BSD-2-Clause AND BSD-3-Clause AND LicenseRef-Fedora-Public-Domain
|
||||
# MIT OR Apache-2.0
|
||||
# Unlicense OR MIT
|
||||
# Zlib
|
||||
License: ((MIT OR Apache-2.0) AND Unicode-DFS-2016) AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND MIT AND (MIT AND Unicode-DFS-2016 AND BSD-2-Clause AND BSD-3-Clause AND LicenseRef-Fedora-Public-Domain) AND (Unlicense OR MIT) AND Zlib
|
||||
# LICENSE.dependencies contains a full license breakdown
|
||||
|
||||
%description -n %{crate} %{_description}
|
||||
|
||||
%files -n %{crate}
|
||||
%license LICENSE
|
||||
%license LICENSE.dependencies
|
||||
%doc README.md
|
||||
%{_bindir}/difft
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
%{cargo_license_summary}
|
||||
%{cargo_license} > LICENSE.dependencies
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.53.1-1
|
||||
- Rebuilt for MSVSphere 9.3
|
||||
|
||||
* Tue Dec 05 2023 Michel Lind <salimma@fedoraproject.org> - 0.53.1-1
|
||||
- Update to 0.53.1
|
||||
|
||||
* Tue Aug 29 2023 Michel Lind <salimma@fedoraproject.org> - 0.51.1-1
|
||||
- Update to 0.51.1
|
||||
|
||||
* Mon Aug 21 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.50.0-2
|
||||
- Fix typo on License field
|
||||
|
||||
* Mon Aug 21 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.50.0-1
|
||||
- Update to 0.50.0
|
||||
|
||||
* Sat Aug 05 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.49.0-1
|
||||
- Update to 0.49.0
|
||||
|
||||
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.45.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Mon Mar 06 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.45.0-2
|
||||
- Lower minimum version of assert_cmd to 2.0.4 (2.0.8 needs cargo2rpm,
|
||||
2.0.5 was never packaged)
|
||||
- rebuild against libmimalloc-sys 0.1.30
|
||||
|
||||
* Sat Mar 04 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.45.0-1
|
||||
- Update to 0.45.0
|
||||
|
||||
* Wed Feb 15 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.43.1-1
|
||||
- Update to 0.43.1
|
||||
|
||||
* Sat Feb 04 2023 Fabio Valentini <decathorpe@gmail.com> - 0.42.0-3
|
||||
- Rebuild for fixed frame pointer compiler flags in Rust RPM macros
|
||||
|
||||
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.42.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Tue Jan 17 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.42.0-1
|
||||
- Update to 0.42.0
|
||||
|
||||
* Thu Jan 05 2023 Michel Alexandre Salim <salimma@fedoraproject.org> - 0.39.0-1
|
||||
- Initial Fedora package
|
Loading…
Reference in new issue