You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-derive_more/SPECS/rust-derive_more.spec

521 lines
16 KiB

## START: Set by rpmautospec
## (rpmautospec version 0.3.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 4;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate derive_more
Name: rust-%{crate}
Version: 0.99.17
Release: %autorelease
Summary: Adds #[derive(x)] macros for more traits
# Upstream license specification: MIT
License: MIT
URL: https://crates.io/crates/derive_more
Source: %{crates_source}
# Initial patched metadata
# * examples are not published
Patch0: derive_more-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
%global _description %{expand:
Adds #[derive(x)] macros for more traits.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+add-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+add-devel %{_description}
This package contains library source intended for building other packages which
use the "add" feature of the "%{crate}" crate.
%files -n %{name}+add-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+add_assign-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+add_assign-devel %{_description}
This package contains library source intended for building other packages which
use the "add_assign" feature of the "%{crate}" crate.
%files -n %{name}+add_assign-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+as_mut-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+as_mut-devel %{_description}
This package contains library source intended for building other packages which
use the "as_mut" feature of the "%{crate}" crate.
%files -n %{name}+as_mut-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+as_ref-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+as_ref-devel %{_description}
This package contains library source intended for building other packages which
use the "as_ref" feature of the "%{crate}" crate.
%files -n %{name}+as_ref-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+constructor-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+constructor-devel %{_description}
This package contains library source intended for building other packages which
use the "constructor" feature of the "%{crate}" crate.
%files -n %{name}+constructor-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+convert_case-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+convert_case-devel %{_description}
This package contains library source intended for building other packages which
use the "convert_case" feature of the "%{crate}" crate.
%files -n %{name}+convert_case-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+deref-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deref-devel %{_description}
This package contains library source intended for building other packages which
use the "deref" feature of the "%{crate}" crate.
%files -n %{name}+deref-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+deref_mut-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+deref_mut-devel %{_description}
This package contains library source intended for building other packages which
use the "deref_mut" feature of the "%{crate}" crate.
%files -n %{name}+deref_mut-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+display-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+display-devel %{_description}
This package contains library source intended for building other packages which
use the "display" feature of the "%{crate}" crate.
%files -n %{name}+display-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+error-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+error-devel %{_description}
This package contains library source intended for building other packages which
use the "error" feature of the "%{crate}" crate.
%files -n %{name}+error-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+from-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+from-devel %{_description}
This package contains library source intended for building other packages which
use the "from" feature of the "%{crate}" crate.
%files -n %{name}+from-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+from_str-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+from_str-devel %{_description}
This package contains library source intended for building other packages which
use the "from_str" feature of the "%{crate}" crate.
%files -n %{name}+from_str-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+generate-parsing-rs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+generate-parsing-rs-devel %{_description}
This package contains library source intended for building other packages which
use the "generate-parsing-rs" feature of the "%{crate}" crate.
%files -n %{name}+generate-parsing-rs-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+index-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+index-devel %{_description}
This package contains library source intended for building other packages which
use the "index" feature of the "%{crate}" crate.
%files -n %{name}+index-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+index_mut-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+index_mut-devel %{_description}
This package contains library source intended for building other packages which
use the "index_mut" feature of the "%{crate}" crate.
%files -n %{name}+index_mut-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+into-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+into-devel %{_description}
This package contains library source intended for building other packages which
use the "into" feature of the "%{crate}" crate.
%files -n %{name}+into-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+into_iterator-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+into_iterator-devel %{_description}
This package contains library source intended for building other packages which
use the "into_iterator" feature of the "%{crate}" crate.
%files -n %{name}+into_iterator-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+is_variant-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+is_variant-devel %{_description}
This package contains library source intended for building other packages which
use the "is_variant" feature of the "%{crate}" crate.
%files -n %{name}+is_variant-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+iterator-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+iterator-devel %{_description}
This package contains library source intended for building other packages which
use the "iterator" feature of the "%{crate}" crate.
%files -n %{name}+iterator-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+mul-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mul-devel %{_description}
This package contains library source intended for building other packages which
use the "mul" feature of the "%{crate}" crate.
%files -n %{name}+mul-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+mul_assign-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+mul_assign-devel %{_description}
This package contains library source intended for building other packages which
use the "mul_assign" feature of the "%{crate}" crate.
%files -n %{name}+mul_assign-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages which
use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+not-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+not-devel %{_description}
This package contains library source intended for building other packages which
use the "not" feature of the "%{crate}" crate.
%files -n %{name}+not-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+peg-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+peg-devel %{_description}
This package contains library source intended for building other packages which
use the "peg" feature of the "%{crate}" crate.
%files -n %{name}+peg-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+rustc_version-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc_version-devel %{_description}
This package contains library source intended for building other packages which
use the "rustc_version" feature of the "%{crate}" crate.
%files -n %{name}+rustc_version-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+sum-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sum-devel %{_description}
This package contains library source intended for building other packages which
use the "sum" feature of the "%{crate}" crate.
%files -n %{name}+sum-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+testing-helpers-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+testing-helpers-devel %{_description}
This package contains library source intended for building other packages which
use the "testing-helpers" feature of the "%{crate}" crate.
%files -n %{name}+testing-helpers-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+track-caller-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+track-caller-devel %{_description}
This package contains library source intended for building other packages which
use the "track-caller" feature of the "%{crate}" crate.
%files -n %{name}+track-caller-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+try_into-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+try_into-devel %{_description}
This package contains library source intended for building other packages which
use the "try_into" feature of the "%{crate}" crate.
%files -n %{name}+try_into-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+unwrap-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unwrap-devel %{_description}
This package contains library source intended for building other packages which
use the "unwrap" feature of the "%{crate}" crate.
%files -n %{name}+unwrap-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Wed Jan 10 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.99.17-4
- Rebuilt for MSVSphere 9.3
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.99.17-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.99.17-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.99.17-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Tue Nov 30 2021 Fabio Valentini <decathorpe@gmail.com> - 0.99.17-1
- Update to version 0.99.17; Fixes RHBZ#2027108
* Fri Jul 09 2021 Fabio Valentini <decathorpe@gmail.com> - 0.99.16-1
- Update to version 0.99.16; Fixes RHBZ#1980159
* Sun May 23 2021 Fabio Valentini <decathorpe@gmail.com> - 0.99.14-1
- Update to version 0.99.14.
- Fixes RHBZ#1960922
* Mon May 10 2021 Fabio Valentini <decathorpe@gmail.com> - 0.99.13-1
- Update to version 0.99.13.
* Mon Mar 29 18:05:23 CEST 2021 Robert-André Mauchin <zebob.m@gmail.com> - 0.99.11-3
- Bump rustc_version to 0.3
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.99.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Thu Oct 01 2020 Fabio Valentini <decathorpe@gmail.com> - 0.99.11-1
- Update to version 0.99.11.
* Fri Sep 11 2020 Josh Stone <jistone@redhat.com> - 0.99.10-1
- Update to 0.99.10
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.99.9-3
- Second attempt - Rebuilt for
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.99.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Fri Jul 10 2020 Josh Stone <jistone@redhat.com> - 0.99.9-1
- Update to 0.99.9
* Fri Jun 19 2020 Josh Stone <jistone@redhat.com> - 0.99.8-1
- Update to 0.99.8
* Sat May 16 19:40:36 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.99.7-1
- Update to 0.99.7
* Thu May 14 2020 Josh Stone <jistone@redhat.com> - 0.99.6-1
- Update to 0.99.6
* Sun Mar 29 09:48:38 CEST 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.99.5-1
- Update to 0.99.5
* Thu Feb 20 2020 Josh Stone <jistone@redhat.com> - 0.99.3-1
- Update to 0.99.3
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.99.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Sat Dec 14 00:21:58 CET 2019 Robert-André Mauchin <zebob.m@gmail.com> - 0.99.2-1
- Update to 0.99.2
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.15.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Tue Jun 18 09:56:43 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.15.0-1
- Update to 0.15.0
* Thu May 30 18:33:43 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.14.1-1
- Initial package