Initial import

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 1201ee1dc7
commit 5961efb811
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -0,0 +1 @@
/derive_builder-0.7.1.crate

@ -0,0 +1,11 @@
--- derive_builder-0.7.1/Cargo.toml 1970-01-01T01:00:00+01:00
+++ derive_builder-0.7.1/Cargo.toml 2019-03-13T18:05:31.131026+01:00
@@ -57,7 +57,7 @@
version = "0.15"
features = ["full", "extra-traits"]
[dev-dependencies.pretty_assertions]
-version = "0.5"
+version = "0.6"
[build-dependencies.env_logger]
version = "0.5"
optional = true

@ -0,0 +1,131 @@
# Generated by rust2rpm
%bcond_with check
%global debug_package %{nil}
%global crate derive_builder
Name: rust-%{crate}
Version: 0.7.1
Release: 1%{?dist}
Summary: Rust macro to automatically implement the builder pattern for arbitrary structs
# Upstream license specification: MIT/Apache-2.0
License: MIT or ASL 2.0
URL: https://crates.io/crates/derive_builder
Source: %{crates_source}
# Initial patched metadata
# * Update pretty_assertions to 0.6, https://github.com/colin-kiegel/rust-derive-builder/pull/143<Paste>
Patch0: derive_builder-fix-metadata.diff
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: (crate(darling/default) >= 0.8.5 with crate(darling/default) < 0.9.0)
BuildRequires: (crate(proc-macro2/default) >= 0.4.0 with crate(proc-macro2/default) < 0.5.0)
BuildRequires: (crate(quote/default) >= 0.6.0 with crate(quote/default) < 0.7.0)
BuildRequires: (crate(syn/default) >= 0.15.0 with crate(syn/default) < 0.16.0)
BuildRequires: (crate(syn/extra-traits) >= 0.15.0 with crate(syn/extra-traits) < 0.16.0)
BuildRequires: (crate(syn/full) >= 0.15.0 with crate(syn/full) < 0.16.0)
BuildRequires: crate(derive_builder_core/default) = 0.4.1
%if %{with check}
BuildRequires: (crate(pretty_assertions/default) >= 0.6.0 with crate(pretty_assertions/default) < 0.7.0)
%endif
%global _description \
Rust macro to automatically implement the builder pattern for arbitrary\
structs.
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
%files devel
%license LICENSE-MIT LICENSE-APACHE
%doc README.md CHANGELOG.md
%{cargo_registry}/%{crate}-%{version}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+env_logger-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+env_logger-devel %{_description}
This package contains library source intended for building other packages
which use "env_logger" feature of "%{crate}" crate.
%files -n %{name}+env_logger-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+log-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+log-devel %{_description}
This package contains library source intended for building other packages
which use "log" feature of "%{crate}" crate.
%files -n %{name}+log-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+logging-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+logging-devel %{_description}
This package contains library source intended for building other packages
which use "logging" feature of "%{crate}" crate.
%files -n %{name}+logging-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+skeptic-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+skeptic-devel %{_description}
This package contains library source intended for building other packages
which use "skeptic" feature of "%{crate}" crate.
%files -n %{name}+skeptic-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Wed Mar 13 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-1
- Initial package

@ -0,0 +1 @@
SHA512 (derive_builder-0.7.1.crate) = 367b7f66c593bfac2b2271e2d55dfb1418d485dd590ee0631cf1297e6d37b66bc6269d7b8c859b24f8e70c76b37e8cd047d463eee18f8013b1aed5b454fe63bc

@ -0,0 +1,5 @@
---
standard-inventory-qcow2:
qemu:
# `cargo test` usually eats more than 1G.
m: 4G

@ -0,0 +1,13 @@
---
- hosts: localhost
roles:
- role: standard-test-basic
tags:
- classic
repositories:
- repo: "https://src.fedoraproject.org/tests/rust.git"
dest: rust
tests:
- rust/cargo-test
environment:
pkg: rust-derive_builder
Loading…
Cancel
Save