Update to 0.7.2

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 3efebca6ea
commit 2d69dd8f6c
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -1 +1,2 @@
/derive_builder-0.7.1.crate
/derive_builder-0.7.2.crate

@ -1,14 +1,5 @@
--- derive_builder-0.7.1/Cargo.toml 1970-01-01T00:00:00+00:00
+++ derive_builder-0.7.1/Cargo.toml 2019-03-25T18:37:13.604497+00:00
@@ -30,7 +30,7 @@
optional = true
[dependencies.darling]
-version = "0.8.5"
+version = "0.9"
[dependencies.derive_builder_core]
version = "=0.4.1"
--- derive_builder-0.7.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ derive_builder-0.7.2/Cargo.toml 2019-06-08T13:30:17.740298+00:00
@@ -57,7 +57,7 @@
version = "0.15"
features = ["full", "extra-traits"]

@ -1,12 +1,12 @@
# Generated by rust2rpm
# Generated by rust2rpm 9
%bcond_with check
%global debug_package %{nil}
%global crate derive_builder
Name: rust-%{crate}
Version: 0.7.1
Release: 2%{?dist}
Version: 0.7.2
Release: 1%{?dist}
Summary: Rust macro to automatically implement the builder pattern for arbitrary structs
# Upstream license specification: MIT/Apache-2.0
@ -15,7 +15,6 @@ URL: https://crates.io/crates/derive_builder
Source: %{crates_source}
# Initial patched metadata
# * Update pretty_assertions to 0.6, https://github.com/colin-kiegel/rust-derive-builder/pull/143
# * Update darling to 0.9, https://github.com/colin-kiegel/rust-derive-builder/pull/144
Patch0: derive_builder-fix-metadata.diff
ExclusiveArch: %{rust_arches}
@ -27,14 +26,14 @@ BuildRequires: (crate(quote/default) >= 0.6.0 with crate(quote/default) < 0.7.0
BuildRequires: (crate(syn/default) >= 0.15.0 with crate(syn/default) < 0.16.0)
BuildRequires: (crate(syn/extra-traits) >= 0.15.0 with crate(syn/extra-traits) < 0.16.0)
BuildRequires: (crate(syn/full) >= 0.15.0 with crate(syn/full) < 0.16.0)
BuildRequires: crate(derive_builder_core/default) = 0.4.1
BuildRequires: crate(derive_builder_core/default) = 0.5.0
%if %{with check}
BuildRequires: (crate(pretty_assertions/default) >= 0.6.0 with crate(pretty_assertions/default) < 0.7.0)
%endif
%global _description \
Rust macro to automatically implement the builder pattern for arbitrary\
structs.
%global _description %{expand:
Rust macro to automatically implement the builder pattern for arbitrary
structs.}
%description %{_description}
@ -64,6 +63,18 @@ which use "default" feature of "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+compiletest_rs-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+compiletest_rs-devel %{_description}
This package contains library source intended for building other packages
which use "compiletest_rs" feature of "%{crate}" crate.
%files -n %{name}+compiletest_rs-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+env_logger-devel
Summary: %{summary}
BuildArch: noarch
@ -100,6 +111,18 @@ which use "logging" feature of "%{crate}" crate.
%files -n %{name}+logging-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+nightlytests-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightlytests-devel %{_description}
This package contains library source intended for building other packages
which use "nightlytests" feature of "%{crate}" crate.
%files -n %{name}+nightlytests-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+skeptic-devel
Summary: %{summary}
BuildArch: noarch
@ -112,6 +135,18 @@ which use "skeptic" feature of "%{crate}" crate.
%files -n %{name}+skeptic-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%package -n %{name}+skeptic_tests-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+skeptic_tests-devel %{_description}
This package contains library source intended for building other packages
which use "skeptic_tests" feature of "%{crate}" crate.
%files -n %{name}+skeptic_tests-devel
%ghost %{cargo_registry}/%{crate}-%{version}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
@ -128,6 +163,9 @@ which use "skeptic" feature of "%{crate}" crate.
%endif
%changelog
* Sat Jun 08 15:30:18 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.2-1
- Update to 0.7.2
* Mon Mar 25 19:37:14 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.7.1-2
- Update darling to 0.9

@ -1 +1 @@
SHA512 (derive_builder-0.7.1.crate) = 367b7f66c593bfac2b2271e2d55dfb1418d485dd590ee0631cf1297e6d37b66bc6269d7b8c859b24f8e70c76b37e8cd047d463eee18f8013b1aed5b454fe63bc
SHA512 (derive_builder-0.7.2.crate) = 8967296adb7ae441d3e354f62166d844ad6251b7314650a791cfbd4b27c6ab68b1f028ffd2bffa3fde767a65ceffc25efd0d55b22faa73ce6cb61670726e41d3

Loading…
Cancel
Save