You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-der_derive0.4/rust-der_derive0.4.spec

76 lines
1.8 KiB

# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate der_derive
Name: rust-der_derive0.4
Version: 0.4.1
Release: %autorelease
Summary: Custom derive support for the der crate's Choice and Message traits
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/der_derive
Source0: %{crates_source}
# https://github.com/RustCrypto/formats/issues/283
Source1: https://github.com/RustCrypto/formats/raw/04219e9/der/derive/LICENSE-APACHE
Source2: https://github.com/RustCrypto/formats/raw/04219e9/der/derive/LICENSE-MIT
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Custom derive support for the `der` crate's `Choice` and `Message`
traits.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
cp -pav %{SOURCE1} %{SOURCE2} .
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog