You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
251 lines
7.2 KiB
251 lines
7.2 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.2)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 2;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 26
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate der
|
|
|
|
Name: rust-der
|
|
Version: 0.7.9
|
|
Release: %autorelease
|
|
Summary: Pure Rust embedded-friendly implementation of DER for ASN.1
|
|
|
|
License: Apache-2.0 OR MIT
|
|
URL: https://crates.io/crates/der
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Pure Rust embedded-friendly implementation of the Distinguished Encoding
|
|
Rules (DER) for Abstract Syntax Notation One (ASN.1) as described in ITU
|
|
X.690 with full support for heapless no_std targets.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+alloc-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+alloc-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "alloc" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+alloc-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+arbitrary-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+arbitrary-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "arbitrary" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+arbitrary-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+bytes-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+bytes-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "bytes" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+bytes-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+derive-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+derive-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "derive" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+derive-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+flagset-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+flagset-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "flagset" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+flagset-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+oid-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+oid-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "oid" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+oid-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+pem-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+pem-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "pem" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+pem-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+real-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+real-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "real" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+real-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+std-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+std-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "std" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+std-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+time-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+time-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "time" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+time-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+zeroize-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+zeroize-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "zeroize" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+zeroize-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.7.9-2
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
## START: Generated by rpmautospec
|
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.9-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Thu Apr 04 2024 Fabio Valentini <decathorpe@gmail.com> - 0.7.9-1
|
|
- Update to version 0.7.9; Fixes RHBZ#2272549
|
|
|
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.8-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Thu Aug 31 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.8-1
|
|
- Update to version 0.7.8; Fixes RHBZ#2229840
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.7-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Wed Jul 05 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.7-1
|
|
- Update to version 0.7.7; Fixes RHBZ#2218547
|
|
|
|
* Wed Jun 07 2023 Fabio Valentini <decathorpe@gmail.com> - 0.7.6-1
|
|
- Update to version 0.7.6; Fixes RHBZ#2082949
|
|
|
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.5-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.5-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.5-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Tue Jan 11 2022 Fabio Valentini <decathorpe@gmail.com> - 0.4.5-1
|
|
- Initial import (#2034212)
|
|
## END: Generated by rpmautospec
|