You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
205 lines
5.3 KiB
205 lines
5.3 KiB
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate der
|
|
|
|
Name: rust-der
|
|
Version: 0.7.8
|
|
Release: %autorelease
|
|
Summary: Pure Rust embedded-friendly implementation of DER for ASN.1
|
|
|
|
License: Apache-2.0 OR MIT
|
|
URL: https://crates.io/crates/der
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Pure Rust embedded-friendly implementation of the Distinguished Encoding
|
|
Rules (DER) for Abstract Syntax Notation One (ASN.1) as described in ITU
|
|
X.690 with full support for heapless no_std targets.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+alloc-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+alloc-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "alloc" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+alloc-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+arbitrary-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+arbitrary-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "arbitrary" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+arbitrary-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+bytes-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+bytes-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "bytes" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+bytes-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+derive-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+derive-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "derive" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+derive-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+flagset-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+flagset-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "flagset" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+flagset-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+oid-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+oid-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "oid" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+oid-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+pem-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+pem-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "pem" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+pem-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+real-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+real-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "real" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+real-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+std-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+std-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "std" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+std-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+time-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+time-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "time" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+time-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+zeroize-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+zeroize-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "zeroize" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+zeroize-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|