You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
106 lines
2.6 KiB
106 lines
2.6 KiB
# Generated by rust2rpm 24
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate darling_core
|
|
|
|
Name: rust-darling_core0.14
|
|
Version: 0.14.4
|
|
Release: %autorelease
|
|
Summary: Parse attributes into structs for custom derive implementations (helper crate)
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/darling_core
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: rust-packaging >= 21
|
|
|
|
%global _description %{expand:
|
|
Helper crate for proc-macro library for reading attributes into structs
|
|
when implementing custom derives. Use https://crates.io/crates/darling
|
|
in your code.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+diagnostics-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+diagnostics-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "diagnostics" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+diagnostics-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+strsim-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+strsim-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "strsim" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+strsim-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+suggestions-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+suggestions-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "suggestions" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+suggestions-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|