You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-cxx/SOURCES/cxx-fix-metadata.diff

30 lines
616 B

--- cxx-1.0.134/Cargo.toml 1970-01-01T00:00:01+00:00
+++ cxx-1.0.134/Cargo.toml 2024-12-16T13:42:33.469082+00:00
@@ -18,11 +18,18 @@
build = "build.rs"
links = "cxxbridge1"
exclude = [
+ "/book",
"/demo",
"/gen",
"/syntax",
"/third-party",
- "/tools/buck/prelude",
+ "/tools/bazel",
+ "/tools/buck",
+ "/BUCK",
+ "/BUILD.bazel",
+ "/MODULE.*",
+ "/reindeer.toml",
+ "/rust-toolchain.toml",
]
autolib = false
autobins = false
@@ -143,6 +150,3 @@
"alloc",
"foldhash/std",
]
-
-[target."cfg(any())".build-dependencies.cxxbridge-cmd]
-version = "=1.0.134"