You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-cursive_buffered_backend/rust-cursive_buffered_backe...

80 lines
1.7 KiB

# Generated by rust2rpm 23
%bcond_without check
%global debug_package %{nil}
%global crate cursive_buffered_backend
Name: rust-cursive_buffered_backend
Version: 0.6.1
Release: %autorelease
Summary: Buffering backend for any Cursive backend
License: MIT
URL: https://crates.io/crates/cursive_buffered_backend
Source: %{crates_source}
BuildRequires: rust-packaging >= 21
BuildRequires: sed
%global _description %{expand:
Buffering backend for any Cursive backend.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%doc %{crate_instdir}/ReleaseInstructions.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
# Fix end of line encoding
for f in CHANGELOG.md LICENSE README.md ReleaseInstructions.md;
do
touch -r $f ${f}.tstamp
sed -i 's/\r$//' $f
touch -r ${f}.tstamp $f
rm ${f}.tstamp
done
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog