Disable tests (broken, require internet access, outdated dependencies)

epel10
Fabio Valentini 5 months ago
parent e10da29a4d
commit 9a950592ca
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

@ -1,5 +1,5 @@
--- curl-0.4.46/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-0.4.46/Cargo.toml 2024-04-25T14:57:35.573247+00:00
+++ curl-0.4.46/Cargo.toml 2024-09-21T18:12:18.021276+00:00
@@ -116,19 +116,9 @@
version = "0.9.64"
optional = true

@ -1,5 +1,5 @@
--- curl-0.4.46/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-0.4.46/Cargo.toml 2024-04-25T14:58:06.815401+00:00
+++ curl-0.4.46/Cargo.toml 2024-09-21T18:12:35.131369+00:00
@@ -25,6 +25,7 @@
]
license = "MIT"
@ -8,14 +8,3 @@
[[example]]
name = "https"
@@ -57,10 +58,6 @@
name = "multi-dl"
path = "examples/multi-dl.rs"
required-features = ["ssl"]
-
-[[test]]
-name = "atexit"
-harness = false
[dependencies.curl-sys]
version = "0.4.72"

@ -1,5 +1,6 @@
# Generated by rust2rpm 26
%bcond_without check
# * tests fail, require internet access, or pull in outdated dependencies
%bcond_with check
%global debug_package %{nil}
%global crate curl
@ -15,7 +16,6 @@ Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: curl-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * drop test binary that requires internet connectivity
# * exclude upstream CI files
Patch: curl-fix-metadata.diff
@ -163,11 +163,6 @@ use the "upkeep_7_62_0" feature of the "%{crate}" crate.
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
# * drop test binary that requires internet connectivity
rm tests/atexit.rs
# * drop test binary that only contains tests that fail:
# likely caused by either libcurl or curl-sys crate updates (FIXME)
rm tests/post.rs
%generate_buildrequires
%cargo_generate_buildrequires
@ -180,10 +175,7 @@ rm tests/post.rs
%if %{with check}
%check
# * skip a test that hangs indefinitely: upload_lots
# * skip two tests that require internet connectivity: src/easy/handle{,r}.rs
# * skip a test that fails with curl 8.7+ for unknown reasons: abort_read
%cargo_test -- -- --skip abort_read --skip upload_lots --skip 'src/easy/handle.rs' --skip 'src/easy/handler.rs'
%cargo_test
%endif
%changelog

@ -1,3 +1,7 @@
[tests]
run = ["none"]
comments = ["tests fail, require internet access, or pull in outdated dependencies"]
[features]
hide = [
"force-system-lib-on-osx",
@ -9,16 +13,3 @@ hide = [
"zlib-ng-compat",
]
[tests]
skip = [
"abort_read",
"upload_lots",
"'src/easy/handle.rs'",
"'src/easy/handler.rs'",
]
comments = [
"skip a test that hangs indefinitely: upload_lots",
"skip two tests that require internet connectivity: src/easy/handle{,r}.rs",
"skip a test that fails with curl 8.7+ for unknown reasons: abort_read",
]

Loading…
Cancel
Save