Update to version 0.4.42

epel9
Fabio Valentini 3 years ago
parent abb67fee0f
commit 4d9a52d8c3
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -17,3 +17,4 @@
/curl-0.4.33.crate
/curl-0.4.40.crate
/curl-0.4.41.crate
/curl-0.4.42.crate

@ -2,4 +2,5 @@
unwanted-features =
force-system-lib-on-osx
mesalink
rustls
zlib-ng-compat

@ -1,16 +1,16 @@
--- curl-0.4.41/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-0.4.41/Cargo.toml 2021-11-26T12:17:16.339213+00:00
@@ -38,9 +38,6 @@
path = "examples/aws_sigv4.rs"
required-features = ["static-curl", "ssl"]
--- curl-0.4.42/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-0.4.42/Cargo.toml 2022-01-27T13:44:01.922753+00:00
@@ -47,9 +47,6 @@
path = "examples/multi-dl.rs"
required-features = ["ssl"]
-[[test]]
-name = "atexit"
-harness = false
[dependencies.curl-sys]
version = "0.4.51"
version = "0.4.52"
default-features = false
@@ -79,12 +76,7 @@
@@ -90,12 +87,7 @@
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9.43"
optional = true

@ -1,11 +1,11 @@
# Generated by rust2rpm 18
# Generated by rust2rpm 20
%bcond_without check
%global debug_package %{nil}
%global crate curl
Name: rust-%{crate}
Version: 0.4.41
Version: 0.4.42
Release: %autorelease
Summary: Rust bindings to libcurl for making HTTP requests
@ -19,9 +19,6 @@ Source: %{crates_source}
Patch0: curl-fix-metadata.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
@ -36,8 +33,8 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages
which use "%{crate}" crate.
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
@ -51,8 +48,8 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages
which use "default" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -63,20 +60,32 @@ BuildArch: noarch
%description -n %{name}+http2-devel %{_description}
This package contains library source intended for building other packages
which use "http2" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "http2" feature of the "%{crate}" crate.
%files -n %{name}+http2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+ntlm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ntlm-devel %{_description}
This package contains library source intended for building other packages which
use the "ntlm" feature of the "%{crate}" crate.
%files -n %{name}+ntlm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+openssl-probe-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+openssl-probe-devel %{_description}
This package contains library source intended for building other packages
which use "openssl-probe" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "openssl-probe" feature of the "%{crate}" crate.
%files -n %{name}+openssl-probe-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -87,8 +96,8 @@ BuildArch: noarch
%description -n %{name}+openssl-sys-devel %{_description}
This package contains library source intended for building other packages
which use "openssl-sys" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "openssl-sys" feature of the "%{crate}" crate.
%files -n %{name}+openssl-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -99,8 +108,8 @@ BuildArch: noarch
%description -n %{name}+poll_7_68_0-devel %{_description}
This package contains library source intended for building other packages
which use "poll_7_68_0" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "poll_7_68_0" feature of the "%{crate}" crate.
%files -n %{name}+poll_7_68_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -111,8 +120,8 @@ BuildArch: noarch
%description -n %{name}+protocol-ftp-devel %{_description}
This package contains library source intended for building other packages
which use "protocol-ftp" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "protocol-ftp" feature of the "%{crate}" crate.
%files -n %{name}+protocol-ftp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -123,8 +132,8 @@ BuildArch: noarch
%description -n %{name}+spnego-devel %{_description}
This package contains library source intended for building other packages
which use "spnego" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "spnego" feature of the "%{crate}" crate.
%files -n %{name}+spnego-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -135,8 +144,8 @@ BuildArch: noarch
%description -n %{name}+ssl-devel %{_description}
This package contains library source intended for building other packages
which use "ssl" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "ssl" feature of the "%{crate}" crate.
%files -n %{name}+ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -147,8 +156,8 @@ BuildArch: noarch
%description -n %{name}+static-curl-devel %{_description}
This package contains library source intended for building other packages
which use "static-curl" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "static-curl" feature of the "%{crate}" crate.
%files -n %{name}+static-curl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -159,8 +168,8 @@ BuildArch: noarch
%description -n %{name}+static-ssl-devel %{_description}
This package contains library source intended for building other packages
which use "static-ssl" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "static-ssl" feature of the "%{crate}" crate.
%files -n %{name}+static-ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
@ -171,8 +180,8 @@ BuildArch: noarch
%description -n %{name}+upkeep_7_62_0-devel %{_description}
This package contains library source intended for building other packages
which use "upkeep_7_62_0" feature of "%{crate}" crate.
This package contains library source intended for building other packages which
use the "upkeep_7_62_0" feature of the "%{crate}" crate.
%files -n %{name}+upkeep_7_62_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml

@ -1 +1 @@
SHA512 (curl-0.4.41.crate) = b26834b32bc9c280f97e9867535e3362921b64557c6ac022435dc666a919b4275fc43b7e201b91934efdd8bc02edd73fde9abfe2a131966ceeb5e302f232bd9e
SHA512 (curl-0.4.42.crate) = d350772332df29e974e5479c8ace920eaa7d39e95cd50e107aa2c519b25525bdc55134733e9b7c665b3cba9f8bd4236c5e0965c419b16a7719f2d83eca878858

Loading…
Cancel
Save