You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-curl-sys/curl-sys-fix-metadata.diff

58 lines
1.4 KiB

--- curl-sys-0.4.39+curl-7.74.0/Cargo.toml 2020-12-09T16:18:44+00:00
+++ curl-sys-0.4.39+curl-7.74.0/Cargo.toml 2020-12-13T00:00:01.208983+00:00
@@ -12,7 +12,7 @@
[package]
name = "curl-sys"
-version = "0.4.39+curl-7.74.0"
+version = "0.4.39"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"
@@ -28,20 +28,6 @@
[dependencies.libc]
version = "0.2.2"
-[dependencies.libnghttp2-sys]
-version = "0.1.3"
-optional = true
-
-[dependencies.libz-sys]
-version = "1.0.18"
-features = ["libc"]
-default-features = false
-
-[dependencies.mesalink]
-version = "1.1.0-cratesio"
-features = ["client_apis", "error_strings", "tls13", "aesgcm", "chachapoly", "x25519", "ecdh", "ecdsa", "verifier"]
-optional = true
-default-features = false
[build-dependencies.cc]
version = "1.0"
@@ -51,21 +37,12 @@
[features]
default = ["ssl"]
force-system-lib-on-osx = []
-http2 = ["libnghttp2-sys"]
+http2 = []
protocol-ftp = []
spnego = []
-ssl = ["openssl-sys"]
+ssl = []
static-curl = []
-static-ssl = ["openssl-sys/vendored"]
-zlib-ng-compat = ["libz-sys/zlib-ng", "static-curl"]
-[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
-version = "0.9"
-optional = true
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["winsock2", "ws2def"]
+static-ssl = []
[badges.appveyor]
repository = "alexcrichton/curl-rust"