Update to version 0.4.55+curl-7.83.1; Fixes RHBZ#2063393

epel9
Fabio Valentini 3 years ago
parent 90a27b3d5c
commit e9e1800c80
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -31,3 +31,4 @@
/curl-sys-0.4.50+curl-7.79.1.crate
/curl-sys-0.4.51+curl-7.80.0.crate
/curl-sys-0.4.52+curl-7.81.0.crate
/curl-sys-0.4.55+curl-7.83.1.crate

@ -1,4 +1,7 @@
[DEFAULT]
unwanted-features =
force-system-lib-on-osx
mesalink
buildrequires =
pkgconfig(libcurl)
lib.requires =

@ -1,15 +1,15 @@
--- curl-sys-0.4.52+curl-7.81.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.52+curl-7.81.0/Cargo.toml 2022-01-27T13:38:15.897909+00:00
--- curl-sys-0.4.55+curl-7.83.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.55+curl-7.83.1/Cargo.toml 2022-05-25T12:16:14.634364+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "curl-sys"
-version = "0.4.52+curl-7.81.0"
+version = "0.4.52"
-version = "0.4.55+curl-7.83.1"
+version = "0.4.55"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"
@@ -28,25 +28,6 @@
@@ -29,20 +29,6 @@
[dependencies.libc]
version = "0.2.2"
@ -22,25 +22,21 @@
-features = ["libc"]
-default-features = false
-
-[dependencies.mesalink]
-version = "1.1.0-cratesio"
-features = ["client_apis", "error_strings", "tls13", "aesgcm", "chachapoly", "x25519", "ecdh", "ecdsa", "verifier"]
-optional = true
-default-features = false
-
-[dependencies.rustls-ffi]
-version = "0.8"
-features = ["no_log_capture"]
-optional = true
-
[build-dependencies.cc]
version = "1.0"
@@ -56,25 +37,18 @@
@@ -52,35 +38,20 @@
[features]
default = ["ssl"]
force-system-lib-on-osx = []
-http2 = ["libnghttp2-sys"]
+http2 = []
mesalink = []
ntlm = []
poll_7_68_0 = []
protocol-ftp = []
@ -51,15 +47,24 @@
-static-ssl = ["openssl-sys/vendored"]
+static-ssl = []
upkeep_7_62_0 = []
-zlib-ng-compat = ["libz-sys/zlib-ng", "static-curl"]
-zlib-ng-compat = [
- "libz-sys/zlib-ng",
- "static-curl",
-]
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9"
optional = true
-
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2"
-
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["winsock2", "ws2def"]
-features = [
- "winsock2",
- "ws2def",
-]
[badges.appveyor]
repository = "alexcrichton/curl-rust"

@ -1,12 +1,12 @@
# Generated by rust2rpm 20
# Generated by rust2rpm 21
%bcond_without check
%global debug_package %{nil}
%global crate curl-sys
%global upstream_version 0.4.52+curl-7.81.0
%global upstream_version 0.4.55+curl-7.83.1
Name: rust-%{crate}
Version: 0.4.52
Version: 0.4.55
Release: %autorelease
Summary: Native bindings to the libcurl library
@ -26,7 +26,7 @@ Patch0001: 0001-Make-static-curl-static-ssl-features-a-noop.patch
ExclusiveArch: %{rust_arches}
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Native bindings to the libcurl library.}
@ -44,8 +44,8 @@ This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license LICENSE
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -57,7 +57,7 @@ This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+force-system-lib-on-osx-devel
Summary: %{summary}
@ -69,7 +69,7 @@ This package contains library source intended for building other packages which
use the "force-system-lib-on-osx" feature of the "%{crate}" crate.
%files -n %{name}+force-system-lib-on-osx-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+http2-devel
Summary: %{summary}
@ -81,7 +81,7 @@ This package contains library source intended for building other packages which
use the "http2" feature of the "%{crate}" crate.
%files -n %{name}+http2-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ntlm-devel
Summary: %{summary}
@ -93,7 +93,7 @@ This package contains library source intended for building other packages which
use the "ntlm" feature of the "%{crate}" crate.
%files -n %{name}+ntlm-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+openssl-sys-devel
Summary: %{summary}
@ -105,7 +105,7 @@ This package contains library source intended for building other packages which
use the "openssl-sys" feature of the "%{crate}" crate.
%files -n %{name}+openssl-sys-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+poll_7_68_0-devel
Summary: %{summary}
@ -117,7 +117,7 @@ This package contains library source intended for building other packages which
use the "poll_7_68_0" feature of the "%{crate}" crate.
%files -n %{name}+poll_7_68_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+protocol-ftp-devel
Summary: %{summary}
@ -129,7 +129,7 @@ This package contains library source intended for building other packages which
use the "protocol-ftp" feature of the "%{crate}" crate.
%files -n %{name}+protocol-ftp-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+spnego-devel
Summary: %{summary}
@ -141,7 +141,7 @@ This package contains library source intended for building other packages which
use the "spnego" feature of the "%{crate}" crate.
%files -n %{name}+spnego-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ssl-devel
Summary: %{summary}
@ -153,7 +153,7 @@ This package contains library source intended for building other packages which
use the "ssl" feature of the "%{crate}" crate.
%files -n %{name}+ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+static-curl-devel
Summary: %{summary}
@ -165,7 +165,7 @@ This package contains library source intended for building other packages which
use the "static-curl" feature of the "%{crate}" crate.
%files -n %{name}+static-curl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+static-ssl-devel
Summary: %{summary}
@ -177,7 +177,7 @@ This package contains library source intended for building other packages which
use the "static-ssl" feature of the "%{crate}" crate.
%files -n %{name}+static-ssl-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+upkeep_7_62_0-devel
Summary: %{summary}
@ -189,7 +189,7 @@ This package contains library source intended for building other packages which
use the "upkeep_7_62_0" feature of the "%{crate}" crate.
%files -n %{name}+upkeep_7_62_0-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{upstream_version} -p1

@ -1 +1 @@
SHA512 (curl-sys-0.4.52+curl-7.81.0.crate) = 86967a065902b06fa00ca23c253e9915fd8e5db16fc5731b4327d6b2bd77ba5552ec96349070329ee15c2b32798b727275305a96e8720c0aef8b47e5a989e640
SHA512 (curl-sys-0.4.55+curl-7.83.1.crate) = 94afabd076ca2729feaf7374c77bc25325439bd556e95d7ee50bed852eab21baa71cfba9a0235aa6438477710324a1589c3b5a9e943aa5cb7dd68b6686cbd947

Loading…
Cancel
Save