parent
769bfea6ea
commit
bbff32297d
@ -0,0 +1 @@
|
||||
/curl-sys-0.3.15.crate
|
@ -0,0 +1,15 @@
|
||||
--- curl-sys-0.3.15/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ curl-sys-0.3.15/Cargo.toml 2017-11-26T12:03:40.409462+01:00
|
||||
@@ -35,12 +35,8 @@
|
||||
|
||||
[build-dependencies.pkg-config]
|
||||
version = "0.3"
|
||||
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
|
||||
-version = "0.2"
|
||||
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
|
||||
version = "0.9"
|
||||
-[target."cfg(windows)".dependencies.winapi]
|
||||
-version = "0.2"
|
||||
[badges.travis-ci]
|
||||
repository = "alexcrichton/curl-rust"
|
||||
|
@ -0,0 +1,68 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate curl-sys
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.3.15
|
||||
Release: 1%{?dist}
|
||||
Summary: Native bindings to the libcurl library
|
||||
|
||||
# https://github.com/alexcrichton/curl-rust/pull/193
|
||||
License: MIT
|
||||
URL: https://crates.io/crates/curl-sys
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * No windows
|
||||
Patch0: curl-sys-0.3.15-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(libc) >= 0.2.0 with crate(libc) < 0.3.0)
|
||||
BuildRequires: crate(libz-sys) >= 0.0.0
|
||||
BuildRequires: (crate(openssl-sys) >= 0.9.0 with crate(openssl-sys) < 0.10.0)
|
||||
# [build-dependencies]
|
||||
BuildRequires: (crate(cc) >= 1.0.0 with crate(cc) < 2.0.0)
|
||||
BuildRequires: (crate(pkg-config) >= 0.3.0 with crate(pkg-config) < 0.4.0)
|
||||
BuildRequires: pkgconfig(libcurl)
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
Requires: pkgconfig(libcurl)
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Native bindings to the libcurl library.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
# No bundled deps
|
||||
rm -vrf curl
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Sun Nov 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.15-1
|
||||
- Initial package
|
Loading…
Reference in new issue