Update to version 0.4.65+curl-8.2.1; Fixes RHBZ#2225628

epel10
Fabio Valentini 2 years ago
parent 62cee257e6
commit a4243a957d
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -36,3 +36,4 @@
/curl-sys-0.4.59+curl-7.86.0.crate
/curl-sys-0.4.60+curl-7.88.1.crate
/curl-sys-0.4.63+curl-8.1.2.crate
/curl-sys-0.4.65+curl-8.2.1.crate

@ -1,17 +1,17 @@
From e3d51c5adba339fe2f1f2434399db940a666034e Mon Sep 17 00:00:00 2001
From 09efbb01afdad57593abde233df70701ccfff180 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Mon, 12 Jun 2023 14:10:33 +0200
Date: Sat, 29 Jul 2023 16:34:22 +0200
Subject: [PATCH] unconditionally use pkg-config to link with system libcurl
---
build.rs | 582 +------------------------------------------------------
1 file changed, 5 insertions(+), 577 deletions(-)
build.rs | 583 +------------------------------------------------------
1 file changed, 5 insertions(+), 578 deletions(-)
diff --git a/build.rs b/build.rs
index aae0ac6..497789c 100644
index 67c2772..497789c 100644
--- a/build.rs
+++ b/build.rs
@@ -1,606 +1,34 @@
@@ -1,607 +1,34 @@
-use std::env;
-use std::fs;
-use std::path::{Path, PathBuf};
@ -53,7 +53,7 @@ index aae0ac6..497789c 100644
-
- if !Path::new("curl/.git").exists() {
- let _ = Command::new("git")
- .args(&["submodule", "update", "--init"])
- .args(&["submodule", "update", "--init", "curl"])
- .status();
- }
-
@ -114,7 +114,7 @@ index aae0ac6..497789c 100644
- .replace("@LIBCURL_LIBS@", "")
- .replace("@SUPPORT_FEATURES@", "")
- .replace("@SUPPORT_PROTOCOLS@", "")
- .replace("@CURLVERSION@", "8.1.2"),
- .replace("@CURLVERSION@", "8.2.1"),
- )
- .unwrap();
-
@ -194,6 +194,7 @@ index aae0ac6..497789c 100644
- .file("curl/lib/llist.c")
- .file("curl/lib/md5.c")
- .file("curl/lib/mime.c")
- .file("curl/lib/macos.c")
- .file("curl/lib/mprintf.c")
- .file("curl/lib/mqtt.c")
- .file("curl/lib/multi.c")

@ -1,7 +1,7 @@
--- curl-sys-0.4.63+curl-8.1.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.63+curl-8.1.2/Cargo.toml 2023-06-12T12:01:26.405394+00:00
--- curl-sys-0.4.65+curl-8.2.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.65+curl-8.2.1/Cargo.toml 2023-07-29T14:25:50.028197+00:00
@@ -73,16 +73,6 @@
version = "0.9"
version = "0.9.64"
optional = true
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]

@ -1,11 +1,11 @@
--- curl-sys-0.4.63+curl-8.1.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.63+curl-8.1.2/Cargo.toml 2023-06-12T12:02:48.309675+00:00
--- curl-sys-0.4.65+curl-8.2.1/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.65+curl-8.2.1/Cargo.toml 2023-07-29T14:26:43.338434+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "curl-sys"
-version = "0.4.63+curl-8.1.2"
+version = "0.4.63"
-version = "0.4.65+curl-8.2.1"
+version = "0.4.65"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"
@ -54,4 +54,4 @@
-]
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9"
version = "0.9.64"

@ -3,10 +3,10 @@
%global debug_package %{nil}
%global crate curl-sys
%global crate_version 0.4.63+curl-8.1.2
%global crate_version 0.4.65+curl-8.2.1
Name: rust-curl-sys
Version: 0.4.63
Version: 0.4.65
Release: %autorelease
Summary: Native bindings to the libcurl library

@ -1 +1 @@
SHA512 (curl-sys-0.4.63+curl-8.1.2.crate) = 50d2cacce02135dc316389eb2c486226f54c930bab26ca732d88b99970112a5528ec0bdd0e98bb82b17a8ed4db56ac82385bb36dbf5049aad376f930a5bfaaf5
SHA512 (curl-sys-0.4.65+curl-8.2.1.crate) = 7e10af5e6e92a9821ffbd6b8823ed7ff2e845795a174bdcb16246c3feca91165d1f17137d3adada3cce80840193028a916a996b696af93a6ab0935471b1d984f

Loading…
Cancel
Save