Update to 0.4.9

epel9
Josh Stone 7 years ago
parent 4858ab6ad7
commit 82b8a5ec29

1
.gitignore vendored

@ -5,3 +5,4 @@
/curl-sys-0.4.6.crate
/curl-sys-0.4.7.crate
/curl-sys-0.4.8.crate
/curl-sys-0.4.9.crate

@ -1,14 +0,0 @@
--- curl-sys-0.4.7/Cargo.toml 1969-12-31T16:00:00-08:00
+++ curl-sys-0.4.7/Cargo.toml 2018-07-30T18:02:18.195700-07:00
@@ -37,11 +37,6 @@
version = "0.3.3"
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9"
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["winsock2", "ws2def"]
[badges.appveyor]
repository = "alexcrichton/curl-rust"

@ -0,0 +1,29 @@
--- curl-sys-0.4.9/Cargo.toml 1969-12-31T16:00:00-08:00
+++ curl-sys-0.4.9/Cargo.toml 2018-09-13T13:07:27.619555-07:00
@@ -28,10 +28,6 @@
[dependencies.libc]
version = "0.2.2"
-[dependencies.libnghttp2-sys]
-version = "0.1"
-optional = true
-
[dependencies.libz-sys]
version = "1.0.18"
[build-dependencies.cc]
@@ -41,14 +37,9 @@
version = "0.3.3"
[features]
-http2 = ["libnghttp2-sys"]
+http2 = []
[target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-sys]
version = "0.9"
-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
-version = "0.2"
-[target."cfg(windows)".dependencies.winapi]
-version = "0.3"
-features = ["winsock2", "ws2def"]
[badges.appveyor]
repository = "alexcrichton/curl-rust"

@ -0,0 +1,11 @@
--- curl-sys-0.4.9/lib.rs.orig 2018-09-12 12:59:06.000000000 -0700
+++ curl-sys-0.4.9/lib.rs 2018-09-13 13:12:04.228581344 -0700
@@ -7,8 +7,6 @@ extern crate libz_sys;
extern crate openssl_sys;
#[cfg(windows)]
extern crate winapi;
-#[cfg(feature = "http2")]
-extern crate libnghttp2_sys;
use libc::{c_int, c_char, c_uint, c_short, c_long, c_double, c_void, size_t, time_t};
use libc::c_ulong;

@ -5,7 +5,7 @@
%global crate curl-sys
Name: rust-%{crate}
Version: 0.4.8
Version: 0.4.9
Release: 1%{?dist}
Summary: Native bindings to the libcurl library
@ -14,7 +14,9 @@ URL: https://crates.io/crates/curl-sys
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
# Initial patched metadata
# * No windows
Patch0: curl-sys-0.4.7-fix-metadata.diff
# * libnghttp2-sys is only needed for bundled curl
Patch0: curl-sys-fix-metadata.diff
Patch1: curl-sys-remove-libnghttp2-sys.diff
ExclusiveArch: %{rust_arches}
@ -64,6 +66,9 @@ rm -vrf curl
%{cargo_registry}/%{crate}-%{version}/
%changelog
* Thu Sep 13 2018 Josh Stone <jistone@redhat.com> - 0.4.9-1
- Update to 0.4.9
* Sat Aug 04 2018 Josh Stone <jistone@redhat.com> - 0.4.8-1
- Update to 0.4.8

@ -1 +1 @@
SHA512 (curl-sys-0.4.8.crate) = 198fbd16722f3a60ee727233c442439519ac0fb9358ad0ac7e65c838dc494ac44d3ba4eb974f326fe67004fe47b38a4246111273c7481907dd8a42f2221ff03c
SHA512 (curl-sys-0.4.9.crate) = af7b37ef96b6ec36ae64f028040d22014c9636957a7929a6ee451d601673ba283b9d7a063de9ef6fd1002ad1475d3ca47811eeef6c42138e8a8574974b89d026

Loading…
Cancel
Save