import rust-curl-sys-0.4.70-1.el9

i9ce changed/i9ce/rust-curl-sys-0.4.70-1.el9
MSVSphere Packaging Team 1 year ago
parent 67985800ad
commit 3a22f2e8bf

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/curl-sys-0.4.70+curl-8.5.0.crate

@ -0,0 +1 @@
e68a1fe901006b9c5e435ab03fb0079229b72336 SOURCES/curl-sys-0.4.70+curl-8.5.0.crate

@ -1,4 +1,4 @@
From e5f806557a9a83492b3000942fa0833316d066cd Mon Sep 17 00:00:00 2001
From fd991562a64708318e9750c1c0345b91a9cd22d2 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Tue, 17 Oct 2023 13:21:16 +0200
Subject: [PATCH] unconditionally use pkg-config to link with system libcurl
@ -8,7 +8,7 @@ Subject: [PATCH] unconditionally use pkg-config to link with system libcurl
1 file changed, 5 insertions(+), 579 deletions(-)
diff --git a/build.rs b/build.rs
index 74f601b..497789c 100644
index 17a6861..497789c 100644
--- a/build.rs
+++ b/build.rs
@@ -1,608 +1,34 @@
@ -114,7 +114,7 @@ index 74f601b..497789c 100644
- .replace("@LIBCURL_LIBS@", "")
- .replace("@SUPPORT_FEATURES@", "")
- .replace("@SUPPORT_PROTOCOLS@", "")
- .replace("@CURLVERSION@", "8.4.0"),
- .replace("@CURLVERSION@", "8.5.0"),
- )
- .unwrap();
-
@ -626,5 +626,5 @@ index 74f601b..497789c 100644
- None
-}
--
2.41.0
2.43.0

@ -1,11 +1,11 @@
--- curl-sys-0.4.68+curl-8.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.68+curl-8.4.0/Cargo.toml 2023-10-17T11:13:59.847744+00:00
--- curl-sys-0.4.70+curl-8.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.70+curl-8.5.0/Cargo.toml 2024-01-13T14:56:26.426384+00:00
@@ -12,7 +12,7 @@
[package]
edition = "2018"
name = "curl-sys"
-version = "0.4.68+curl-8.4.0"
+version = "0.4.68"
-version = "0.4.70+curl-8.5.0"
+version = "0.4.70"
authors = ["Alex Crichton <alex@alexcrichton.com>"]
build = "build.rs"
links = "curl"

@ -1,5 +1,5 @@
--- curl-sys-0.4.68+curl-8.4.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.68+curl-8.4.0/Cargo.toml 2023-10-17T11:14:46.252970+00:00
--- curl-sys-0.4.70+curl-8.5.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ curl-sys-0.4.70+curl-8.5.0/Cargo.toml 2024-01-13T14:57:15.083595+00:00
@@ -29,20 +29,6 @@
[dependencies.libc]
version = "0.2.2"

@ -0,0 +1,4 @@
[requires]
build = ["pkgconfig(libcurl)"]
lib = ["pkgconfig(libcurl)"]

@ -13,10 +13,10 @@
%global debug_package %{nil}
%global crate curl-sys
%global upstream_version 0.4.68+curl-8.4.0
%global upstream_version 0.4.70+curl-8.5.0
Name: rust-curl-sys
Version: 0.4.68
Version: 0.4.70
Release: %autorelease
Summary: Native bindings to the libcurl library
@ -167,9 +167,9 @@ use the "upkeep_7_62_0" feature of the "%{crate}" crate.
%prep
%autosetup -n %{crate}-%{upstream_version} -p1
%cargo_prep
# remove bundled curl sources
rm -vr curl/
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
@ -187,9 +187,12 @@ echo 'pkgconfig(libcurl)'
%endif
%changelog
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.68-1
* Mon Jan 15 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.4.70-1
- Rebuilt for MSVSphere 9.3
* Sat Jan 13 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.70-1
- Update to version 0.4.70+curl-8.5.0; Fixes RHBZ#2253472
* Tue Oct 17 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.68-1
- Update to version 0.4.68+curl-8.4.0; Fixes RHBZ#2242878

Loading…
Cancel
Save