Update to 1.1.0

Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
epel9
Igor Gnatenko 6 years ago
parent 0fc56997f4
commit c7c83c1e6b
No known key found for this signature in database
GPG Key ID: 695714BD1BBC5F4C

1
.gitignore vendored

@ -4,3 +4,4 @@
/csv-1.0.5.crate
/csv-1.0.6.crate
/csv-1.0.7.crate
/csv-1.1.0.crate

@ -1,28 +0,0 @@
From 58c6ccbda090f72be62b31e840e1808c9b49265f Mon Sep 17 00:00:00 2001
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
Date: Sun, 12 May 2019 08:15:07 +0200
Subject: [PATCH] chore: Update serde_bytes to 0.11
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
---
src/deserializer.rs | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/deserializer.rs b/src/deserializer.rs
index 9d1d980..6ab72ae 100644
--- a/src/deserializer.rs
+++ b/src/deserializer.rs
@@ -1014,8 +1014,8 @@ mod tests {
#[test]
fn bytes() {
- let got: Vec<u8> = de::<ByteBuf>(&["foobar"]).unwrap().into();
- assert_eq!(got, b"foobar".to_vec());
+ let got = de::<ByteBuf>(&["foobar"]).unwrap();
+ assert_eq!(got, b"foobar");
}
#[test]
--
2.21.0

@ -1,11 +0,0 @@
--- csv-1.0.7/Cargo.toml 1970-01-01T00:00:00+00:00
+++ csv-1.0.7/Cargo.toml 2019-05-12T06:37:15.185944+00:00
@@ -43,7 +43,7 @@
[dependencies.serde]
version = "1.0.55"
[dev-dependencies.serde_bytes]
-version = "0.10.4"
+version = "0.11"
[dev-dependencies.serde_derive]
version = "1.0.55"

@ -5,19 +5,14 @@
%global crate csv
Name: rust-%{crate}
Version: 1.0.7
Release: 4%{?dist}
Version: 1.1.0
Release: 1%{?dist}
Summary: Fast CSV parsing with support for serde
# Upstream license specification: Unlicense/MIT
License: Unlicense or MIT
URL: https://crates.io/crates/csv
Source: %{crates_source}
# Initial patched metadata
# * Update serde_bytes to 0.11, https://github.com/BurntSushi/rust-csv/pull/154
Patch0: csv-fix-metadata.diff
# Make it work with new serde_bytes
Patch0001: 0001-chore-Update-serde_bytes-to-0.11.patch
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
@ -76,6 +71,9 @@ which use "default" feature of "%{crate}" crate.
%endif
%changelog
* Thu Jun 27 07:25:28 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.1.0-1
- Update to 1.1.0
* Thu Jun 20 16:47:21 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.7-4
- Regenerate

@ -1 +1 @@
SHA512 (csv-1.0.7.crate) = d3e69e0a93b55617b79a32e4429ea56eee03b5b01a9a62a132a41c0a4961db1bff418681ac3ebbfa30cb0c82ce2beeab2d9fa469a0514e5ff9ef64b969de4acb
SHA512 (csv-1.1.0.crate) = 4c777e940ca539ba9d89e4945918a00deae7164a2bdc0a29f9b58bc003733fe898a152ecc841c7c12e8f99998cc55e90f4f054304140c3fe2576f659175ed03f

Loading…
Cancel
Save