parent
5966679635
commit
ae6578cc3a
@ -0,0 +1 @@
|
||||
/csv-core-0.1.4.crate
|
@ -0,0 +1,11 @@
|
||||
--- csv-core-0.1.4/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ csv-core-0.1.4/Cargo.toml 2018-06-14T08:44:14.607427+02:00
|
||||
@@ -34,7 +34,7 @@
|
||||
version = "2"
|
||||
default-features = false
|
||||
[dev-dependencies.arrayvec]
|
||||
-version = "0.3"
|
||||
+version = "0.4"
|
||||
default-features = false
|
||||
|
||||
[features]
|
@ -0,0 +1,64 @@
|
||||
# Generated by rust2rpm
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate csv-core
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.1.4
|
||||
Release: 1%{?dist}
|
||||
Summary: Bare bones CSV parsing with no_std support
|
||||
|
||||
License: Unlicense or MIT
|
||||
URL: https://crates.io/crates/csv-core
|
||||
Source0: https://crates.io/api/v1/crates/%{crate}/%{version}/download#/%{crate}-%{version}.crate
|
||||
# Initial patched metadata
|
||||
# * Bump arrayvec to 0.4, https://github.com/BurntSushi/rust-csv/commit/9030a4a5f3c04cfecea69cca5b934c589f81427e
|
||||
Patch0: csv-core-0.1.4-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
# [dependencies]
|
||||
BuildRequires: (crate(memchr) >= 2.0.0 with crate(memchr) < 3.0.0)
|
||||
%if %{with check}
|
||||
# [dev-dependencies]
|
||||
BuildRequires: (crate(arrayvec) >= 0.4.0 with crate(arrayvec) < 0.5.0)
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel
|
||||
Bare bones CSV parsing with no_std support.
|
||||
|
||||
This package contains library source intended for building other packages
|
||||
which use %{crate} from crates.io.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%files devel
|
||||
%license COPYING LICENSE-MIT UNLICENSE
|
||||
%doc README.md
|
||||
%{cargo_registry}/%{crate}-%{version}/
|
||||
|
||||
%changelog
|
||||
* Thu Jun 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.4-1
|
||||
- Initial package
|
Loading…
Reference in new issue