Initial import (#2031169)
parent
a6f938b1d1
commit
f89b73c36b
@ -0,0 +1,4 @@
|
||||
/results_*/
|
||||
/*.src.rpm
|
||||
|
||||
/crypto-bigint-0.2.11.crate
|
@ -0,0 +1,21 @@
|
||||
--- crypto-bigint-0.2.11/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ crypto-bigint-0.2.11/Cargo.toml 2021-12-10T16:22:13.642298+00:00
|
||||
@@ -32,17 +32,12 @@
|
||||
version = "0.6"
|
||||
optional = true
|
||||
|
||||
-[dependencies.rlp]
|
||||
-version = "0.5"
|
||||
-optional = true
|
||||
-default-features = false
|
||||
-
|
||||
[dependencies.subtle]
|
||||
version = "2.4"
|
||||
default-features = false
|
||||
|
||||
[dependencies.zeroize]
|
||||
-version = ">=1, <1.5"
|
||||
+version = "1"
|
||||
optional = true
|
||||
default-features = false
|
||||
[dev-dependencies.hex-literal]
|
@ -0,0 +1,137 @@
|
||||
# Generated by rust2rpm 20
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate crypto-bigint
|
||||
|
||||
Name: rust-%{crate}
|
||||
Version: 0.2.11
|
||||
Release: %autorelease
|
||||
Summary: Pure Rust bigint implementation for use in cryptographic applications
|
||||
|
||||
# Upstream license specification: Apache-2.0 OR MIT
|
||||
License: ASL 2.0 or MIT
|
||||
URL: https://crates.io/crates/crypto-bigint
|
||||
Source: %{crates_source}
|
||||
# Initial patched metadata
|
||||
# * drop optional rlp dependency (not packaged yet)
|
||||
# * relax zeroize dependency
|
||||
Patch0: crypto-bigint-fix-metadata.diff
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
BuildRequires: rust-packaging
|
||||
|
||||
%global _description %{expand:
|
||||
Pure Rust implementation of a big integer library which has been designed from
|
||||
the ground-up for use in cryptographic applications. Provides constant-time,
|
||||
no_std-friendly implementations of modern formulas using const generics.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license LICENSE-APACHE LICENSE-MIT
|
||||
%doc CHANGELOG.md README.md
|
||||
%{cargo_registry}/%{crate}-%{version_no_tilde}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+alloc-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+alloc-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "alloc" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+alloc-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+generic-array-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+generic-array-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "generic-array" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+generic-array-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rand" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rand_core-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rand_core-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rand_core" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rand_core-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%package -n %{name}+zeroize-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+zeroize-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "zeroize" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+zeroize-devel
|
||||
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
%autochangelog
|
Loading…
Reference in new issue