commit 25df9ac8e85c409063f4962ebac2ed8dd7b44c0e
Author: tigro <tigro@msvsphere-os.ru>
Date:   Mon Nov 20 11:38:42 2023 +0300

    import rust-crunchy-0.2.2-5.el9

diff --git a/.rust-crunchy.metadata b/.rust-crunchy.metadata
new file mode 100644
index 0000000..e69de29
diff --git a/SOURCES/crunchy-0.2.2.crate b/SOURCES/crunchy-0.2.2.crate
new file mode 100644
index 0000000..5e94742
Binary files /dev/null and b/SOURCES/crunchy-0.2.2.crate differ
diff --git a/SPECS/rust-crunchy.spec b/SPECS/rust-crunchy.spec
new file mode 100644
index 0000000..a68a9bc
--- /dev/null
+++ b/SPECS/rust-crunchy.spec
@@ -0,0 +1,181 @@
+## START: Set by rpmautospec
+## (rpmautospec version 0.2.5)
+%define autorelease(e:s:pb:) %{?-p:0.}%{lua:
+    release_number = 5;
+    base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
+    print(release_number + base_release_number - 1);
+}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{?dist}
+## END: Set by rpmautospec
+
+# Generated by rust2rpm 19
+%bcond_without check
+%global debug_package %{nil}
+
+%global crate crunchy
+
+Name:           rust-%{crate}
+Version:        0.2.2
+Release:        %autorelease
+Summary:        Crunchy unroller: deterministically unroll constant loops
+
+# Upstream license specification: MIT
+# https://github.com/Vurich/crunchy/issues/6
+License:        MIT
+URL:            https://crates.io/crates/crunchy
+Source:         %{crates_source}
+
+ExclusiveArch:  %{rust_arches}
+%if %{__cargo_skip_build}
+BuildArch:      noarch
+%endif
+
+BuildRequires:  rust-packaging
+
+%global _description %{expand:
+Crunchy unroller: deterministically unroll constant loops.}
+
+%description %{_description}
+
+%package        devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description    devel %{_description}
+
+This package contains library source intended for building other packages which
+use "%{crate}" crate.
+
+%files          devel
+%doc README.md
+%{cargo_registry}/%{crate}-%{version_no_tilde}/
+
+%package     -n %{name}+default-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+default-devel %{_description}
+
+This package contains library source intended for building other packages which
+use "the default" feature of the "%{crate}" crate.
+
+%files       -n %{name}+default-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%package     -n %{name}+limit_1024-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+limit_1024-devel %{_description}
+
+This package contains library source intended for building other packages which
+use "the limit_1024" feature of the "%{crate}" crate.
+
+%files       -n %{name}+limit_1024-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%package     -n %{name}+limit_128-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+limit_128-devel %{_description}
+
+This package contains library source intended for building other packages which
+use "the limit_128" feature of the "%{crate}" crate.
+
+%files       -n %{name}+limit_128-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%package     -n %{name}+limit_2048-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+limit_2048-devel %{_description}
+
+This package contains library source intended for building other packages which
+use "the limit_2048" feature of the "%{crate}" crate.
+
+%files       -n %{name}+limit_2048-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%package     -n %{name}+limit_256-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+limit_256-devel %{_description}
+
+This package contains library source intended for building other packages which
+use "the limit_256" feature of the "%{crate}" crate.
+
+%files       -n %{name}+limit_256-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%package     -n %{name}+limit_512-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+limit_512-devel %{_description}
+
+This package contains library source intended for building other packages which
+use "the limit_512" feature of the "%{crate}" crate.
+
+%files       -n %{name}+limit_512-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%package     -n %{name}+limit_64-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+limit_64-devel %{_description}
+
+This package contains library source intended for building other packages which
+use "the limit_64" feature of the "%{crate}" crate.
+
+%files       -n %{name}+limit_64-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%package     -n %{name}+std-devel
+Summary:        %{summary}
+BuildArch:      noarch
+
+%description -n %{name}+std-devel %{_description}
+
+This package contains library source intended for building other packages which
+use "the std" feature of the "%{crate}" crate.
+
+%files       -n %{name}+std-devel
+%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+
+%prep
+%autosetup -n %{crate}-%{version_no_tilde} -p1
+%cargo_prep
+
+%generate_buildrequires
+%cargo_generate_buildrequires
+
+%build
+%cargo_build
+
+%install
+%cargo_install
+
+%if %{with check}
+%check
+%cargo_test
+%endif
+
+%changelog
+* Mon Nov 20 2023 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.2.2-5
+- Rebuilt for MSVSphere 9.2
+
+* Wed Dec 29 2021 Igor Raits <ignatenkobrain@fedoraproject.org> 0.2.2-5
+- Rebuild
+
+* Sun Nov 28 2021 Igor Raits <ignatenkobrain@fedoraproject.org> 0.2.2-4
+- Regenerate
+
+* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
+
+* Sat Feb 27 19:56:14 CET 2021 Fabio Valentini <decathorpe@gmail.com> - 0.2.2-1
+- Initial package
+