You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
149 lines
4.0 KiB
149 lines
4.0 KiB
# Generated by rust2rpm 25
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate crossterm
|
|
|
|
Name: rust-crossterm
|
|
Version: 0.27.0
|
|
Release: %autorelease
|
|
Summary: Crossplatform terminal library for manipulating terminals
|
|
|
|
License: MIT
|
|
URL: https://crates.io/crates/crossterm
|
|
Source: %{crates_source}
|
|
# Automatically generated patch to strip dependencies and normalize metadata
|
|
Patch: crossterm-fix-metadata-auto.diff
|
|
# Manually created patch for downstream crate metadata changes
|
|
# * drop Windows-specific features
|
|
Patch: crossterm-fix-metadata.diff
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
A crossplatform terminal library for manipulating terminals.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE
|
|
%doc %{crate_instdir}/CHANGELOG.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+bracketed-paste-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+bracketed-paste-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "bracketed-paste" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+bracketed-paste-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+event-stream-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+event-stream-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "event-stream" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+event-stream-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+events-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+events-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "events" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+events-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+filedescriptor-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+filedescriptor-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "filedescriptor" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+filedescriptor-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+serde-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+serde-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "serde" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+serde-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+use-dev-tty-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+use-dev-tty-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "use-dev-tty" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+use-dev-tty-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
# * skip two tests that randomly fail:
|
|
# https://github.com/crossterm-rs/crossterm/issues/836
|
|
%cargo_test -- -- --exact --skip style::types::colored::tests::test_parse_ansi_bg --skip style::types::colored::tests::test_parse_ansi_fg
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|