Update to version 0.9.18; Fixes RHBZ#2257268

epel10
Fabio Valentini 1 year ago
parent 1a9b38fff6
commit cd95e377b4
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -26,3 +26,4 @@
/crossbeam-epoch-0.9.14.crate
/crossbeam-epoch-0.9.15.crate
/crossbeam-epoch-0.9.17.crate
/crossbeam-epoch-0.9.18.crate

@ -1,25 +0,0 @@
From 1cead3c1acf440d13bfa09a636a70531337f170d Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Mon, 9 Oct 2023 01:19:01 +0200
Subject: [PATCH] Remove redundant clone() call to fix builds with Rust 1.73+
---
src/guard.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/guard.rs b/src/guard.rs
index ba7fe1b..32c82e6 100644
--- a/src/guard.rs
+++ b/src/guard.rs
@@ -448,7 +448,7 @@ impl fmt::Debug for Guard {
/// a.load(Relaxed, epoch::unprotected());
///
/// // It's possible to create more dummy guards by calling `clone()`.
-/// let dummy = &epoch::unprotected().clone();
+/// let dummy = &epoch::unprotected();
///
/// dummy.defer(move || {
/// println!("This gets executed immediately.");
--
2.41.0

@ -1,6 +1,6 @@
--- crossbeam-epoch-0.9.17/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossbeam-epoch-0.9.17/Cargo.toml 2023-12-27T20:28:23.715342+00:00
@@ -48,7 +48,6 @@
--- crossbeam-epoch-0.9.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossbeam-epoch-0.9.18/Cargo.toml 2024-01-11T17:27:01.731050+00:00
@@ -42,7 +42,6 @@
alloc = []
default = ["std"]
loom = [
@ -8,7 +8,7 @@
"crossbeam-utils/loom",
]
nightly = ["crossbeam-utils/nightly"]
@@ -57,7 +56,3 @@
@@ -51,7 +50,3 @@
"crossbeam-utils/std",
]

@ -1,6 +1,6 @@
--- crossbeam-epoch-0.9.17/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossbeam-epoch-0.9.17/Cargo.toml 2023-12-27T20:28:39.797416+00:00
@@ -47,9 +47,6 @@
--- crossbeam-epoch-0.9.18/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossbeam-epoch-0.9.18/Cargo.toml 2024-01-11T17:27:11.140087+00:00
@@ -41,9 +41,6 @@
[features]
alloc = []
default = ["std"]

@ -5,7 +5,7 @@
%global crate crossbeam-epoch
Name: rust-crossbeam-epoch
Version: 0.9.17
Version: 0.9.18
Release: %autorelease
Summary: Epoch-based garbage collection

@ -1 +1 @@
SHA512 (crossbeam-epoch-0.9.17.crate) = 9bdeb0415ea26250547ed9f34a8dd4c17f9379e3c56f8f17315e48f9bf63ce1b79c37786ead0f4df026e31b0b5965d181c36839d891c14149529ac42b5cedea4
SHA512 (crossbeam-epoch-0.9.18.crate) = 0a8a199b9d77f4e28e91fe0a0cbff7e0dec58cac283631fd972477fa912d2f6ddfddaed2c695e4978b01cb5440b702822af6333e7c3dfbcb9a2c2086999516b2

Loading…
Cancel
Save