Merge branch 'rawhide' into epel9

epel9
Fabio Valentini 2 years ago
commit b3b5848c75
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

5
.gitignore vendored

@ -16,3 +16,8 @@
/crossbeam-epoch-0.9.3.crate
/crossbeam-epoch-0.9.4.crate
/crossbeam-epoch-0.9.5.crate
/crossbeam-epoch-0.9.6.crate
/crossbeam-epoch-0.9.7.crate
/crossbeam-epoch-0.9.8.crate
/crossbeam-epoch-0.9.9.crate
/crossbeam-epoch-0.9.10.crate

@ -0,0 +1,18 @@
--- crossbeam-epoch-0.9.10/Cargo.toml 1970-01-01T00:00:01+00:00
+++ crossbeam-epoch-0.9.10/Cargo.toml 1970-01-01T00:00:01+00:00
@@ -62,7 +62,6 @@
alloc = []
default = ["std"]
loom = [
- "loom-crate",
"crossbeam-utils/loom",
]
nightly = ["crossbeam-utils/nightly"]
@@ -72,7 +71,3 @@
"once_cell",
]
-[target."cfg(crossbeam_loom)".dependencies.loom-crate]
-version = "0.5"
-optional = true
-package = "loom"

@ -1,13 +0,0 @@
--- crossbeam-epoch-0.9.5/Cargo.toml 1970-01-01T00:00:00+00:00
+++ crossbeam-epoch-0.9.5/Cargo.toml 2021-06-02T10:38:03.846851+00:00
@@ -49,10 +49,5 @@
[features]
alloc = []
default = ["std"]
-loom = ["loom-crate", "crossbeam-utils/loom"]
nightly = ["crossbeam-utils/nightly", "const_fn"]
std = ["alloc", "crossbeam-utils/std", "lazy_static"]
-[target."cfg(crossbeam_loom)".dependencies.loom-crate]
-version = "0.5"
-optional = true
-package = "loom"

@ -1,28 +1,23 @@
# Generated by rust2rpm 19
# Generated by rust2rpm 22
%bcond_without check
%global debug_package %{nil}
%global crate crossbeam-epoch
Name: rust-%{crate}
Version: 0.9.5
Name: rust-crossbeam-epoch
Version: 0.9.10
Release: %autorelease
Summary: Epoch-based garbage collection
# Upstream license specification: MIT OR Apache-2.0
License: MIT or ASL 2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/crossbeam-epoch
Source: %{crates_source}
# Initial patched metadata
# * drop unused loom dev-dependency
Patch0: crossbeam-epoch-fix-metadata.diff
# Automatically generated patch to strip foreign dependencies
Patch: crossbeam-epoch-fix-metadata-auto.diff
ExclusiveArch: %{rust_arches}
%if %{__cargo_skip_build}
BuildArch: noarch
%endif
BuildRequires: rust-packaging
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Epoch-based garbage collection.}
@ -36,12 +31,14 @@ BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use "%{crate}" crate.
use the "%{crate}" crate.
%files devel
%license LICENSE-APACHE LICENSE-MIT
%doc CHANGELOG.md README.md
%{cargo_registry}/%{crate}-%{version_no_tilde}/
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
@ -50,10 +47,10 @@ BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use "the default" feature of the "%{crate}" crate.
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
@ -62,46 +59,34 @@ BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use "the alloc" feature of the "%{crate}" crate.
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+const_fn-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+const_fn-devel %{_description}
This package contains library source intended for building other packages which
use "the const_fn" feature of the "%{crate}" crate.
%ghost %{crate_instdir}/Cargo.toml
%files -n %{name}+const_fn-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%package -n %{name}+lazy_static-devel
%package -n %{name}+nightly-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+lazy_static-devel %{_description}
%description -n %{name}+nightly-devel %{_description}
This package contains library source intended for building other packages which
use "the lazy_static" feature of the "%{crate}" crate.
use the "nightly" feature of the "%{crate}" crate.
%files -n %{name}+lazy_static-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%files -n %{name}+nightly-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+nightly-devel
%package -n %{name}+once_cell-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+nightly-devel %{_description}
%description -n %{name}+once_cell-devel %{_description}
This package contains library source intended for building other packages which
use "the nightly" feature of the "%{crate}" crate.
use the "once_cell" feature of the "%{crate}" crate.
%files -n %{name}+nightly-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%files -n %{name}+once_cell-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
@ -110,10 +95,10 @@ BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use "the std" feature of the "%{crate}" crate.
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1

@ -0,0 +1,3 @@
[DEFAULT]
unwanted-features =
loom

@ -1 +1 @@
SHA512 (crossbeam-epoch-0.9.5.crate) = ad822e967e5ef45fa0c4a939f057f44146f1f051032fd032355a75c0f45ae4e0a55e1d31c80bc67c01ff8d9c87a51aba7ccfe9a440f061fd8225c879aa663064
SHA512 (crossbeam-epoch-0.9.10.crate) = c8e103daf27a06798e4cc89c6263c08117ba7cef322421b7f91e6a96137c2fa2371ce9cf31e8d1a752be85f4feea90d4da21f1921a0a0c618c1f66ef67a5bf03

Loading…
Cancel
Save