diff --git a/.gitignore b/.gitignore
index 2b9f68b..1839173 100644
--- a/.gitignore
+++ b/.gitignore
@@ -9,3 +9,4 @@
 /crossbeam-deque-0.7.3.crate
 /crossbeam-deque-0.8.0.crate
 /crossbeam-deque-0.8.1.crate
+/crossbeam-deque-0.8.2.crate
diff --git a/rust-crossbeam-deque.spec b/rust-crossbeam-deque.spec
index cd5131c..9067415 100644
--- a/rust-crossbeam-deque.spec
+++ b/rust-crossbeam-deque.spec
@@ -1,25 +1,21 @@
-# Generated by rust2rpm 18
+# Generated by rust2rpm 22
 %bcond_without check
 %global debug_package %{nil}
 
 %global crate crossbeam-deque
 
-Name:           rust-%{crate}
-Version:        0.8.1
+Name:           rust-crossbeam-deque
+Version:        0.8.2
 Release:        %autorelease
 Summary:        Concurrent work-stealing deque
 
-# Upstream license specification: MIT OR Apache-2.0
-License:        MIT or ASL 2.0
+License:        MIT OR Apache-2.0
 URL:            https://crates.io/crates/crossbeam-deque
 Source:         %{crates_source}
 
 ExclusiveArch:  %{rust_arches}
-%if %{__cargo_skip_build}
-BuildArch:      noarch
-%endif
 
-BuildRequires:  rust-packaging
+BuildRequires:  rust-packaging >= 21
 
 %global _description %{expand:
 Concurrent work-stealing deque.}
@@ -32,13 +28,15 @@ BuildArch:      noarch
 
 %description    devel %{_description}
 
-This package contains library source intended for building other packages
-which use "%{crate}" crate.
+This package contains library source intended for building other packages which
+use the "%{crate}" crate.
 
 %files          devel
-%license LICENSE-MIT LICENSE-APACHE
-%doc README.md CHANGELOG.md
-%{cargo_registry}/%{crate}-%{version_no_tilde}/
+%license %{crate_instdir}/LICENSE-APACHE
+%license %{crate_instdir}/LICENSE-MIT
+%doc %{crate_instdir}/CHANGELOG.md
+%doc %{crate_instdir}/README.md
+%{crate_instdir}/
 
 %package     -n %{name}+default-devel
 Summary:        %{summary}
@@ -46,11 +44,11 @@ BuildArch:      noarch
 
 %description -n %{name}+default-devel %{_description}
 
-This package contains library source intended for building other packages
-which use "default" feature of "%{crate}" crate.
+This package contains library source intended for building other packages which
+use the "default" feature of the "%{crate}" crate.
 
 %files       -n %{name}+default-devel
-%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+%ghost %{crate_instdir}/Cargo.toml
 
 %package     -n %{name}+crossbeam-epoch-devel
 Summary:        %{summary}
@@ -58,11 +56,11 @@ BuildArch:      noarch
 
 %description -n %{name}+crossbeam-epoch-devel %{_description}
 
-This package contains library source intended for building other packages
-which use "crossbeam-epoch" feature of "%{crate}" crate.
+This package contains library source intended for building other packages which
+use the "crossbeam-epoch" feature of the "%{crate}" crate.
 
 %files       -n %{name}+crossbeam-epoch-devel
-%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+%ghost %{crate_instdir}/Cargo.toml
 
 %package     -n %{name}+crossbeam-utils-devel
 Summary:        %{summary}
@@ -70,11 +68,11 @@ BuildArch:      noarch
 
 %description -n %{name}+crossbeam-utils-devel %{_description}
 
-This package contains library source intended for building other packages
-which use "crossbeam-utils" feature of "%{crate}" crate.
+This package contains library source intended for building other packages which
+use the "crossbeam-utils" feature of the "%{crate}" crate.
 
 %files       -n %{name}+crossbeam-utils-devel
-%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+%ghost %{crate_instdir}/Cargo.toml
 
 %package     -n %{name}+std-devel
 Summary:        %{summary}
@@ -82,11 +80,11 @@ BuildArch:      noarch
 
 %description -n %{name}+std-devel %{_description}
 
-This package contains library source intended for building other packages
-which use "std" feature of "%{crate}" crate.
+This package contains library source intended for building other packages which
+use the "std" feature of the "%{crate}" crate.
 
 %files       -n %{name}+std-devel
-%ghost %{cargo_registry}/%{crate}-%{version_no_tilde}/Cargo.toml
+%ghost %{crate_instdir}/Cargo.toml
 
 %prep
 %autosetup -n %{crate}-%{version_no_tilde} -p1
diff --git a/sources b/sources
index 8a45cc4..1aaf752 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (crossbeam-deque-0.8.1.crate) = 44a4fe1d4ab7457e2b0950be787b76b15e1bb0b1c108d032381ce3fe99bf7bf76f3d1718085660083d813e2639e66fdd3635d9186e85a9eb7267063b117eaca4
+SHA512 (crossbeam-deque-0.8.2.crate) = a50a878d843d6eb1b5b92321ce6bfb87a23d3c16e820b1ff55472f0bd3d29b41d09ea95e1b9ccb2790f6687c043dd9ada1cd5124705e24292ccbd8fae1f243b3