You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
rust-convert_case0.4/rust-convert_case0.4.spec

101 lines
2.4 KiB

# Generated by rust2rpm 25
%bcond_without check
%global debug_package %{nil}
%global crate convert_case
Name: rust-convert_case0.4
Version: 0.4.0
Release: %autorelease
Summary: Convert strings into any case
License: MIT
URL: https://crates.io/crates/convert_case
Source: %{crates_source}
Source: https://raw.githubusercontent.com/rutrum/convert-case/master/LICENSE
# Manually created patch for downstream crate metadata changes
# * bump strum and strum_macros from 0.18 to 0.21.0:
# https://github.com/rutrum/convert-case/pull/3
# * disable LTO to work around LLVM crashes on ppc64le:
# https://bugzilla.redhat.com/show_bug.cgi?id=2142648
Patch: convert_case-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Convert strings into any case.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rand-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rand-devel %{_description}
This package contains library source intended for building other packages which
use the "rand" feature of the "%{crate}" crate.
%files -n %{name}+rand-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+random-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+random-devel %{_description}
This package contains library source intended for building other packages which
use the "random" feature of the "%{crate}" crate.
%files -n %{name}+random-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
cp -p %{SOURCE1} LICENSE
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog