You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
273 lines
7.4 KiB
273 lines
7.4 KiB
# Generated by rust2rpm 25
|
|
%bcond_without check
|
|
%global debug_package %{nil}
|
|
|
|
%global crate const_format
|
|
|
|
Name: rust-const_format
|
|
Version: 0.2.32
|
|
Release: %autorelease
|
|
Summary: Compile-time string formatting
|
|
|
|
License: Zlib
|
|
URL: https://crates.io/crates/const_format
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Compile-time string formatting.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-ZLIB.md
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+__debug-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+__debug-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "__debug" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+__debug-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+__docsrs-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+__docsrs-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "__docsrs" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+__docsrs-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+__only_new_tests-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+__only_new_tests-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "__only_new_tests" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+__only_new_tests-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+__test-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+__test-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "__test" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+__test-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+all-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+all-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "all" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+all-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+assert-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+assert-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "assert" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+assert-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+assertc-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+assertc-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "assertc" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+assertc-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+assertcp-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+assertcp-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "assertcp" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+assertcp-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+const_generics-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+const_generics-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "const_generics" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+const_generics-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+constant_time_as_str-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+constant_time_as_str-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "constant_time_as_str" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+constant_time_as_str-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+derive-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+derive-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "derive" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+derive-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+fmt-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+fmt-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "fmt" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+fmt-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+konst-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+konst-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "konst" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+konst-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+more_str_macros-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+more_str_macros-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "more_str_macros" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+more_str_macros-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+nightly_const_generics-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+nightly_const_generics-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "nightly_const_generics" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+nightly_const_generics-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+rust_1_51-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+rust_1_51-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "rust_1_51" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+rust_1_51-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%package -n %{name}+rust_1_64-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+rust_1_64-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "rust_1_64" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+rust_1_64-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test -f __test
|
|
%endif
|
|
|
|
%changelog
|
|
%autochangelog
|