You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
128 lines
3.8 KiB
128 lines
3.8 KiB
## START: Set by rpmautospec
|
|
## (rpmautospec version 0.7.3)
|
|
## RPMAUTOSPEC: autorelease, autochangelog
|
|
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
|
release_number = 1;
|
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
|
print(release_number + base_release_number - 1);
|
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
|
## END: Set by rpmautospec
|
|
|
|
# Generated by rust2rpm 27
|
|
%bcond check 1
|
|
%global debug_package %{nil}
|
|
|
|
%global crate clap-verbosity-flag
|
|
|
|
Name: rust-clap-verbosity-flag
|
|
Version: 2.2.3
|
|
Release: %autorelease
|
|
Summary: Easily add a --verbose flag to CLIs using Clap
|
|
|
|
License: MIT OR Apache-2.0
|
|
URL: https://crates.io/crates/clap-verbosity-flag
|
|
Source: %{crates_source}
|
|
|
|
BuildRequires: cargo-rpm-macros >= 24
|
|
|
|
%global _description %{expand:
|
|
Easily add a `--verbose` flag to CLIs using Clap.}
|
|
|
|
%description %{_description}
|
|
|
|
%package devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "%{crate}" crate.
|
|
|
|
%files devel
|
|
%license %{crate_instdir}/LICENSE-APACHE
|
|
%license %{crate_instdir}/LICENSE-MIT
|
|
%doc %{crate_instdir}/README.md
|
|
%{crate_instdir}/
|
|
|
|
%package -n %{name}+default-devel
|
|
Summary: %{summary}
|
|
BuildArch: noarch
|
|
|
|
%description -n %{name}+default-devel %{_description}
|
|
|
|
This package contains library source intended for building other packages which
|
|
use the "default" feature of the "%{crate}" crate.
|
|
|
|
%files -n %{name}+default-devel
|
|
%ghost %{crate_instdir}/Cargo.toml
|
|
|
|
%prep
|
|
%autosetup -n %{crate}-%{version} -p1
|
|
%cargo_prep
|
|
|
|
%generate_buildrequires
|
|
%cargo_generate_buildrequires
|
|
|
|
%build
|
|
%cargo_build
|
|
|
|
%install
|
|
%cargo_install
|
|
|
|
%if %{with check}
|
|
%check
|
|
%cargo_test
|
|
%endif
|
|
|
|
%changelog
|
|
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 2.2.3-1
|
|
- Rebuilt for MSVSphere 10
|
|
|
|
## START: Generated by rpmautospec
|
|
* Thu Nov 28 2024 Fabio Valentini <decathorpe@gmail.com> - 2.2.3-1
|
|
- Update to version 2.2.3
|
|
|
|
* Sat Oct 05 2024 Fabio Valentini <decathorpe@gmail.com> - 2.2.2-1
|
|
- Update to version 2.2.2; Fixes RHBZ#2314986
|
|
|
|
* Sun Jul 28 2024 Fabio Valentini <decathorpe@gmail.com> - 2.2.1-1
|
|
- Update to version 2.2.1; Fixes RHBZ#2299864
|
|
|
|
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.0-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
|
|
|
* Thu Feb 29 2024 Fabio Valentini <decathorpe@gmail.com> - 2.2.0-1
|
|
- Update to version 2.2.0; Fixes RHBZ#2264245
|
|
|
|
* Tue Jan 30 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.2-1
|
|
- Update to version 2.1.2; Fixes RHBZ#2258663
|
|
|
|
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.1-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
|
|
|
* Wed Jan 10 2024 Fabio Valentini <decathorpe@gmail.com> - 2.1.1-1
|
|
- Update to version 2.1.1; Fixes RHBZ#2254771
|
|
|
|
* Tue Oct 24 2023 Fabio Valentini <decathorpe@gmail.com> - 2.1.0-1
|
|
- Update to version 2.1.0; Fixes RHBZ#2245656
|
|
|
|
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.1-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
|
|
|
* Tue Jun 13 2023 Fabio Valentini <decathorpe@gmail.com> - 2.0.1-1
|
|
- Update to version 2.0.1; Fixes RHBZ#2036401
|
|
|
|
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-4
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
|
|
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-3
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
|
|
|
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-2
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
|
|
|
* Fri Aug 27 2021 Davide Cavalca <dcavalca@fedoraproject.org> - 0.3.2-1
|
|
- Initial import; Fixes: RHBZ#1990149
|
|
## END: Generated by rpmautospec
|