From bc2924a3747e6d3077a656434f11e9a53196da40 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Mon, 30 Jan 2023 17:38:06 +0100
Subject: [PATCH] Add missing runtime dependency on clang-libs

---
 rust-clang-sys.spec | 5 ++---
 rust2rpm.conf       | 4 +++-
 2 files changed, 5 insertions(+), 4 deletions(-)

diff --git a/rust-clang-sys.spec b/rust-clang-sys.spec
index d209406..3f61d36 100644
--- a/rust-clang-sys.spec
+++ b/rust-clang-sys.spec
@@ -1,4 +1,4 @@
-# Generated by rust2rpm 22
+# Generated by rust2rpm 23
 %bcond_without check
 %global debug_package %{nil}
 
@@ -16,8 +16,6 @@ Source:         %{crates_source}
 # * exclude files that are only useful for upstream development
 Patch:          clang-sys-fix-metadata.diff
 
-ExclusiveArch:  %{rust_arches}
-
 BuildRequires:  rust-packaging >= 21
 
 %global _description %{expand:
@@ -289,6 +287,7 @@ use the "libloading" feature of the "%{crate}" crate.
 %package     -n %{name}+runtime-devel
 Summary:        %{summary}
 BuildArch:      noarch
+Requires:       clang-libs
 
 %description -n %{name}+runtime-devel %{_description}
 
diff --git a/rust2rpm.conf b/rust2rpm.conf
index 8b6cc3e..858ad19 100644
--- a/rust2rpm.conf
+++ b/rust2rpm.conf
@@ -1,6 +1,6 @@
 [DEFAULT]
 unwanted-features =
-  clang_16_0  
+  clang_16_0
 buildrequires =
   clang-devel >= 3.5
 lib+default.requires =
@@ -39,3 +39,5 @@ lib+clang_14_0.requires =
   clang-devel >= 14.0
 lib+clang_15_0.requires =
   clang-devel >= 15.0
+lib+runtime.requires =
+  clang-libs