parent
cfb8751131
commit
b1c8205fb0
@ -0,0 +1,35 @@
|
||||
From 7a6a33fc6290dbb712f6c2682f6054ec467d718d Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Tue, 7 May 2019 14:06:40 +0200
|
||||
Subject: [PATCH] chore: Update glob to 0.3
|
||||
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
build/common.rs | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/build/common.rs b/build/common.rs
|
||||
index 44e58e0..ed69d4b 100644
|
||||
--- a/build/common.rs
|
||||
+++ b/build/common.rs
|
||||
@@ -77,7 +77,7 @@ fn search_directory(directory: &Path, filenames: &[String]) -> Vec<(PathBuf, Str
|
||||
options.require_literal_separator = true;
|
||||
|
||||
paths.flat_map(|p| {
|
||||
- if let Ok(paths) = glob::glob_with(&p, &options) {
|
||||
+ if let Ok(paths) = glob::glob_with(&p, options) {
|
||||
paths.filter_map(Result::ok).collect()
|
||||
} else {
|
||||
vec![]
|
||||
@@ -155,7 +155,7 @@ pub fn search_libclang_directories(files: &[String], variable: &str) -> Vec<(Pat
|
||||
options.case_sensitive = false;
|
||||
options.require_literal_separator = true;
|
||||
for directory in directories.iter().rev() {
|
||||
- if let Ok(directories) = glob::glob_with(directory, &options) {
|
||||
+ if let Ok(directories) = glob::glob_with(directory, options) {
|
||||
for directory in directories.filter_map(Result::ok).filter(|p| p.is_dir()) {
|
||||
found.extend(search_directories(&directory, files));
|
||||
}
|
||||
--
|
||||
2.21.0
|
||||
|
@ -1,10 +1,22 @@
|
||||
--- clang-sys-0.28.0/Cargo.toml 1970-01-01T01:00:00+01:00
|
||||
+++ clang-sys-0.28.0/Cargo.toml 2019-03-16T22:51:08.284446+01:00
|
||||
@@ -21,6 +21,7 @@
|
||||
--- clang-sys-0.28.0/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ clang-sys-0.28.0/Cargo.toml 2019-05-07T12:25:04.096136+00:00
|
||||
@@ -21,8 +21,9 @@
|
||||
readme = "README.md"
|
||||
license = "Apache-2.0"
|
||||
repository = "https://github.com/KyleMayes/clang-sys"
|
||||
+exclude = ["/appveyor.yml", "/ci/*", "/clippy.toml"]
|
||||
[dependencies.glob]
|
||||
version = "0.2.11"
|
||||
-version = "0.2.11"
|
||||
+version = "0.3"
|
||||
|
||||
[dependencies.libc]
|
||||
version = "0.2.39"
|
||||
@@ -32,7 +33,7 @@
|
||||
version = "0.5.0"
|
||||
optional = true
|
||||
[build-dependencies.glob]
|
||||
-version = "0.2.11"
|
||||
+version = "0.3"
|
||||
|
||||
[features]
|
||||
clang_3_5 = []
|
||||
|
@ -0,0 +1 @@
|
||||
1
|
@ -0,0 +1,5 @@
|
||||
---
|
||||
standard-inventory-qcow2:
|
||||
qemu:
|
||||
# `cargo test` usually eats more than 1G.
|
||||
m: 4G
|
@ -0,0 +1,13 @@
|
||||
---
|
||||
- hosts: localhost
|
||||
roles:
|
||||
- role: standard-test-basic
|
||||
tags:
|
||||
- classic
|
||||
repositories:
|
||||
- repo: "https://src.fedoraproject.org/tests/rust.git"
|
||||
dest: rust
|
||||
tests:
|
||||
- rust/cargo-test
|
||||
environment:
|
||||
pkg: rust-clang-sys
|
Loading…
Reference in new issue