import rust-chrono-0.4.39-1.el10

i10ce changed/i10ce/rust-chrono-0.4.39-1.el10
MSVSphere Packaging Team 2 months ago
commit 3a00c9a504
Signed by: sys_gitsync
GPG Key ID: B2B0B9F29E528FE8

1
.gitignore vendored

@ -0,0 +1 @@
SOURCES/chrono-0.4.39.crate

@ -0,0 +1 @@
00ad293540ae73a6558c23a359c865f7abcc47a5 SOURCES/chrono-0.4.39.crate

@ -0,0 +1,46 @@
--- chrono-0.4.39/Cargo.toml 1970-01-01T00:00:01+00:00
+++ chrono-0.4.39/Cargo.toml 2024-12-09T19:37:10.552603+00:00
@@ -109,7 +109,6 @@
clock = [
"winapi",
"iana-time-zone",
- "android-tzdata",
"now",
]
default = [
@@ -141,34 +140,11 @@
std = ["alloc"]
unstable-locales = ["pure-rust-locales"]
wasmbind = [
- "wasm-bindgen",
- "js-sys",
]
-winapi = ["windows-targets"]
-
-[target.'cfg(all(target_arch = "wasm32", not(any(target_os = "emscripten", target_os = "wasi"))))'.dependencies.js-sys]
-version = "0.3"
-optional = true
-
-[target.'cfg(all(target_arch = "wasm32", not(any(target_os = "emscripten", target_os = "wasi"))))'.dependencies.wasm-bindgen]
-version = "0.2"
-optional = true
-
-[target.'cfg(all(target_arch = "wasm32", not(any(target_os = "emscripten", target_os = "wasi"))))'.dev-dependencies.wasm-bindgen-test]
-version = "0.3"
-
-[target.'cfg(target_os = "android")'.dependencies.android-tzdata]
-version = "0.1.1"
-optional = true
+winapi = []
[target."cfg(unix)".dependencies.iana-time-zone]
version = "0.1.45"
features = ["fallback"]
optional = true
-[target."cfg(windows)".dependencies.windows-targets]
-version = "0.52"
-optional = true
-
-[target."cfg(windows)".dev-dependencies.windows-bindgen]
-version = "0.58"

@ -0,0 +1,31 @@
--- chrono-0.4.39/Cargo.toml 1970-01-01T00:00:01+00:00
+++ chrono-0.4.39/Cargo.toml 2024-12-09T19:37:10.554603+00:00
@@ -104,10 +104,8 @@
version = "1"
[features]
-__internal_bench = []
alloc = []
clock = [
- "winapi",
"iana-time-zone",
"now",
]
@@ -115,7 +113,6 @@
"clock",
"std",
"oldtime",
- "wasmbind",
]
libc = []
now = ["std"]
@@ -139,9 +136,6 @@
rkyv-validation = ["rkyv?/validation"]
std = ["alloc"]
unstable-locales = ["pure-rust-locales"]
-wasmbind = [
-]
-winapi = []
[target."cfg(unix)".dependencies.iana-time-zone]
version = "0.1.45"

@ -0,0 +1,5 @@
[package]
cargo-toml-patch-comments = [
"remove WASM- and Windows-specific features",
]

@ -0,0 +1,441 @@
## START: Set by rpmautospec
## (rpmautospec version 0.7.3)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 1;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate chrono
Name: rust-chrono
Version: 0.4.39
Release: %autorelease
Summary: Date and time library for Rust
License: MIT OR Apache-2.0
URL: https://crates.io/crates/chrono
Source: %{crates_source}
# Automatically generated patch to strip dependencies and normalize metadata
Patch: chrono-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes
# * remove WASM- and Windows-specific features
Patch: chrono-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Date and time library for Rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE.txt
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+arbitrary-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+arbitrary-devel %{_description}
This package contains library source intended for building other packages which
use the "arbitrary" feature of the "%{crate}" crate.
%files -n %{name}+arbitrary-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+clock-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+clock-devel %{_description}
This package contains library source intended for building other packages which
use the "clock" feature of the "%{crate}" crate.
%files -n %{name}+clock-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+iana-time-zone-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+iana-time-zone-devel %{_description}
This package contains library source intended for building other packages which
use the "iana-time-zone" feature of the "%{crate}" crate.
%files -n %{name}+iana-time-zone-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+libc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+libc-devel %{_description}
This package contains library source intended for building other packages which
use the "libc" feature of the "%{crate}" crate.
%files -n %{name}+libc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+now-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+now-devel %{_description}
This package contains library source intended for building other packages which
use the "now" feature of the "%{crate}" crate.
%files -n %{name}+now-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+oldtime-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+oldtime-devel %{_description}
This package contains library source intended for building other packages which
use the "oldtime" feature of the "%{crate}" crate.
%files -n %{name}+oldtime-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+pure-rust-locales-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+pure-rust-locales-devel %{_description}
This package contains library source intended for building other packages which
use the "pure-rust-locales" feature of the "%{crate}" crate.
%files -n %{name}+pure-rust-locales-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-16-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-16-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv-16" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-16-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-32-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-32-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv-32" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-32-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-64-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-64-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv-64" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-64-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rkyv-validation-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rkyv-validation-devel %{_description}
This package contains library source intended for building other packages which
use the "rkyv-validation" feature of the "%{crate}" crate.
%files -n %{name}+rkyv-validation-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+serde-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+serde-devel %{_description}
This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.
%files -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+unstable-locales-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+unstable-locales-devel %{_description}
This package contains library source intended for building other packages which
use the "unstable-locales" feature of the "%{crate}" crate.
%files -n %{name}+unstable-locales-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.4.39-1
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Mon Dec 09 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.39-1
- Update to version 0.4.39; Fixes RHBZ#2331130
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.38-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Mon Apr 15 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.38-1
- Update to version 0.4.38; Fixes RHBZ#2271640
* Fri Mar 08 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.35-1
- Update to version 0.4.35; Fixes RHBZ#2268172
* Mon Feb 19 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.34-1
- Update to version 0.4.34; Fixes RHBZ#2263704
* Tue Jan 30 2024 Fabio Valentini <decathorpe@gmail.com> - 0.4.33-1
- Update to version 0.4.33; Fixes RHBZ#2259728
* Fri Jan 26 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.31-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Tue Sep 19 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.31-1
- Update to version 0.4.31; Fixes RHBZ#2236287
* Wed Aug 30 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.27-2
- Skip a test that hard-codes 64-bit arch-specific type sizes
* Wed Aug 30 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.27-1
- Update to version 0.4.27; Fixes RHBZ#2235737
* Fri Jul 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.26-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Wed May 31 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.26-1
- Update to version 0.4.26; Fixes RHBZ#2211223
* Mon May 29 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.25-1
- Update to version 0.4.25; Fixes RHBZ#2210747
* Sun Mar 12 2023 Fabio Valentini <decathorpe@gmail.com> - 0.4.24-1
- Update to version 0.4.24; Fixes RHBZ#2177544
* Fri Jan 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.23-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Sat Dec 10 2022 Fabio Valentini <decathorpe@gmail.com> - 0.4.23-1
- Update to version 0.4.23; Fixes RHBZ#2142264
* Fri Nov 04 2022 Fabio Valentini <decathorpe@gmail.com> - 0.4.22-2
- Drop unused, benchmark-only criterion dev-dependency
* Thu Aug 18 2022 Fabio Valentini <decathorpe@gmail.com> - 0.4.22-1
- Update to version 0.4.22; Fixes RHBZ#2116963
* Sat Aug 06 2022 Fabio Valentini <decathorpe@gmail.com> - 0.4.20-1
- Update to version 0.4.20; Fixes RHBZ#2115406
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.19-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Fri Jan 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.19-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.19-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.19-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Thu Oct 01 2020 Fabio Valentini <decathorpe@gmail.com> - 0.4.19-1
- Update to version 0.4.19.
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.13-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Fri Jul 10 2020 Josh Stone <jistone@redhat.com> - 0.4.13-1
- Update to 0.4.13
* Tue Mar 10 2020 Josh Stone <jistone@redhat.com> - 0.4.11-1
- Update to 0.4.11
* Tue Feb 18 16:57:46 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.4.10-4
- Fix FTBFS, take two
* Tue Feb 18 16:29:36 CET 2020 Igor Raits <ignatenkobrain@fedoraproject.org> - 0.4.10-3
- Fix FTBFS
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.10-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Mon Dec 02 11:03:49 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.10-1
- Update to 0.4.10
* Fri Nov 01 14:12:37 CET 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.9-1
- Update to 0.4.9
* Sun Sep 01 17:08:26 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.8-1
- Update to 0.4.8
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.7-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Tue Jun 25 08:23:16 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.7-1
- Update to 0.4.7
* Fri Jun 21 20:15:18 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.6-7
- Regenerate
* Tue Jun 11 22:50:13 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.6-6
- Rebuild with tests
* Sun Jun 09 21:35:37 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.6-5
- Regenerate
* Sun Mar 10 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.6-4
- Do not pull optional dependencies
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Wed Oct 31 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.6-2
- Adapt to new packaging
* Thu Aug 30 2018 Josh Stone <jistone@redhat.com> - 0.4.6-1
- Update to 0.4.6
* Sun Jul 29 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.5-1
- Update to 0.4.5
* Sat Jul 28 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.4-3
- Rebuild to trigger tests
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Sun Jun 24 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.4-1
- Update to 0.4.4
* Mon Jun 11 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.3-1
- Update to 0.4.3
* Fri Apr 13 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.2-1
- Update to 0.4.2
* Wed Mar 28 2018 Josh Stone <jistone@redhat.com> - 0.4.1-1
- Update to 0.4.1
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Mon Jan 08 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-3
- Rebuild for rust-packaging v5
* Thu Nov 16 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-2
- Exclude unneeded files
* Mon Jun 26 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.4.0-1
- Update to 0.4.0
* Fri Jun 16 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.1-1
- Initial package
## END: Generated by rpmautospec
Loading…
Cancel
Save