i10ce
changed/i10ce/rust-cargo-util-schemas-0.3.1-2.el10
commit
f4351d04a0
@ -0,0 +1 @@
|
||||
SOURCES/cargo-util-schemas-0.3.1.crate
|
@ -0,0 +1 @@
|
||||
6a4af7244a717d7f7e1ecb06bebab55f585c5da3 SOURCES/cargo-util-schemas-0.3.1.crate
|
@ -0,0 +1,15 @@
|
||||
--- cargo-util-schemas-0.3.1/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ cargo-util-schemas-0.3.1/Cargo.toml 2024-06-24T17:54:31.454474+00:00
|
||||
@@ -46,10 +46,10 @@
|
||||
version = "2.5.0"
|
||||
|
||||
[dev-dependencies.snapbox]
|
||||
-version = "0.5.9"
|
||||
+version = "0.6.5"
|
||||
features = [
|
||||
"diff",
|
||||
- "path",
|
||||
+ "dir",
|
||||
"term-svg",
|
||||
]
|
||||
|
@ -0,0 +1,51 @@
|
||||
diff --git a/src/core/partial_version.rs b/src/core/partial_version.rs
|
||||
index 5057d6046e1..00252f56aa0 100644
|
||||
--- a/src/core/partial_version.rs
|
||||
+++ b/src/core/partial_version.rs
|
||||
@@ -186,6 +186,7 @@ enum ErrorKind {
|
||||
#[cfg(test)]
|
||||
mod test {
|
||||
use super::*;
|
||||
+ use snapbox::prelude::*;
|
||||
use snapbox::str;
|
||||
|
||||
#[test]
|
||||
@@ -202,7 +203,7 @@ mod test {
|
||||
Ok(result) => result.to_string(),
|
||||
Err(err) => format!("didn't pass: {err}"),
|
||||
};
|
||||
- snapbox::assert_eq(expected.clone(), actual);
|
||||
+ snapbox::assert_data_eq!(actual, expected.clone().raw());
|
||||
}
|
||||
}
|
||||
|
||||
@@ -241,7 +242,7 @@ mod test {
|
||||
Ok(result) => format!("didn't fail: {result:?}"),
|
||||
Err(err) => err.to_string(),
|
||||
};
|
||||
- snapbox::assert_eq(expected.clone(), actual);
|
||||
+ snapbox::assert_data_eq!(actual, expected.clone().raw());
|
||||
}
|
||||
}
|
||||
}
|
||||
diff --git a/src/manifest/rust_version.rs b/src/manifest/rust_version.rs
|
||||
index 5c40097737f..7afcf92bd80 100644
|
||||
--- a/src/manifest/rust_version.rs
|
||||
+++ b/src/manifest/rust_version.rs
|
||||
@@ -106,6 +106,7 @@ enum RustVersionErrorKind {
|
||||
#[cfg(test)]
|
||||
mod test {
|
||||
use super::*;
|
||||
+ use snapbox::prelude::*;
|
||||
use snapbox::str;
|
||||
|
||||
#[test]
|
||||
@@ -212,7 +213,7 @@ mod test {
|
||||
Ok(result) => format!("didn't fail: {result:?}"),
|
||||
Err(err) => err.to_string(),
|
||||
};
|
||||
- snapbox::assert_eq(expected.clone(), actual);
|
||||
+ snapbox::assert_data_eq!(actual, expected.clone().raw());
|
||||
}
|
||||
}
|
||||
}
|
@ -0,0 +1,100 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.7.2)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 2;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 26
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate cargo-util-schemas
|
||||
|
||||
Name: rust-cargo-util-schemas
|
||||
Version: 0.3.1
|
||||
Release: %autorelease
|
||||
Summary: Deserialization schemas for Cargo
|
||||
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/cargo-util-schemas
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# * bump snapbox dev-dependency from 0.5.9 to 0.6.5:
|
||||
# https://github.com/rust-lang/cargo/pull/13963
|
||||
Patch: cargo-util-schemas-fix-metadata.diff
|
||||
# * backport upstream port to snapbox 0.6:
|
||||
# https://github.com/rust-lang/cargo/commit/4a6f25c
|
||||
Patch: port-to-snapbox-0.6.patch
|
||||
|
||||
BuildRequires: cargo-rpm-macros >= 24
|
||||
|
||||
%global _description %{expand:
|
||||
Deserialization schemas for Cargo.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.3.1-2
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Mon Jun 24 2024 Fabio Valentini <decathorpe@gmail.com> - 0.3.1-1
|
||||
- Update to version 0.3.1; Fixes RHBZ#2292643
|
||||
|
||||
* Sun May 19 2024 Fabio Valentini <decathorpe@gmail.com> - 0.3.0-1
|
||||
- Update to version 0.3.0
|
||||
|
||||
* Mon May 13 2024 Fabio Valentini <decathorpe@gmail.com> - 0.2.0-1
|
||||
- Initial import (#2279110)
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue