Update to version 0.9.27+cargo-0.74.0; Fixes RHBZ#2130183

epel9
Fabio Valentini 1 year ago
parent 65c67f3c4d
commit e2789ecb7e
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -15,3 +15,4 @@
/cargo-c-0.9.7+cargo-0.59.crate /cargo-c-0.9.7+cargo-0.59.crate
/cargo-c-0.9.12+cargo-0.64.crate /cargo-c-0.9.12+cargo-0.64.crate
/cargo-c-0.9.19+cargo-0.70.crate /cargo-c-0.9.19+cargo-0.70.crate
/cargo-c-0.9.27+cargo-0.74.0.crate

@ -1,11 +1,20 @@
--- cargo-c-0.9.19+cargo-0.70/Cargo.toml 1970-01-01T00:00:01+00:00 --- cargo-c-0.9.27+cargo-0.74.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ cargo-c-0.9.19+cargo-0.70/Cargo.toml 2023-05-30T00:43:00.463588+00:00 +++ cargo-c-0.9.27+cargo-0.74.0/Cargo.toml 2023-11-11T11:12:03.277637+00:00
@@ -103,15 +103,3 @@ @@ -13,7 +13,7 @@
edition = "2021"
rust-version = "1.70"
name = "cargo-c"
-version = "0.9.27+cargo-0.74.0"
+version = "0.9.27"
authors = ["Luca Barbato <lu_zero@gentoo.org>"]
description = "Helper program to build and install c-like libraries"
readme = "README.md"
@@ -103,15 +103,4 @@
default = [] default = []
vendored-openssl = ["cargo/vendored-openssl"] vendored-openssl = ["cargo/vendored-openssl"]
-[target."cfg(windows)".dependencies.windows-sys] -[target."cfg(windows)".dependencies.windows-sys]
-version = "0.45" -version = "0.48"
-features = [ -features = [
- "Win32_Foundation", - "Win32_Foundation",
- "Win32_Storage_FileSystem", - "Win32_Storage_FileSystem",
@ -16,3 +25,4 @@
- "Win32_Security", - "Win32_Security",
- "Win32_System_SystemServices", - "Win32_System_SystemServices",
-] -]
+

@ -1,17 +1,9 @@
--- cargo-c-0.9.19+cargo-0.70/Cargo.toml 1970-01-01T00:00:01+00:00 --- cargo-c-0.9.27+cargo-0.74.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ cargo-c-0.9.19+cargo-0.70/Cargo.toml 2023-05-30T00:43:18.828699+00:00 +++ cargo-c-0.9.27+cargo-0.74.0/Cargo.toml 2023-11-11T11:12:10.373660+00:00
@@ -13,7 +13,7 @@ @@ -101,6 +101,5 @@
edition = "2021"
rust-version = "1.69"
name = "cargo-c"
-version = "0.9.19+cargo-0.70"
+version = "0.9.19"
authors = ["Luca Barbato <lu_zero@gentoo.org>"]
description = "Helper program to build and install c-like libraries"
readme = "README.md"
@@ -101,5 +101,3 @@
[features] [features]
default = [] default = []
-vendored-openssl = ["cargo/vendored-openssl"] -vendored-openssl = ["cargo/vendored-openssl"]
-

@ -1,14 +1,14 @@
# Generated by rust2rpm 24 # Generated by rust2rpm 25
%bcond_without check %bcond_without check
# reduce debuginfo verbosity to work around OOM problems on 32-bit arches # reduce debuginfo verbosity to work around OOM problems on 32-bit arches
%global rustflags_debuginfo 1 %global rustflags_debuginfo 1
%global crate cargo-c %global crate cargo-c
%global upstream_version 0.9.19+cargo-0.70 %global upstream_version 0.9.27+cargo-0.74.0
Name: rust-cargo-c Name: rust-cargo-c
Version: 0.9.19 Version: 0.9.27
Release: %autorelease Release: %autorelease
Summary: Helper program to build and install c-like libraries Summary: Helper program to build and install c-like libraries
@ -16,14 +16,14 @@ License: MIT
URL: https://crates.io/crates/cargo-c URL: https://crates.io/crates/cargo-c
Source0: %{crates_source %{crate} %{upstream_version}} Source0: %{crates_source %{crate} %{upstream_version}}
Source1: macros.cargo-c Source1: macros.cargo-c
# Automatically generated patch to strip foreign dependencies # Automatically generated patch to strip dependencies and normalize metadata
Patch: cargo-c-fix-metadata-auto.diff Patch: cargo-c-fix-metadata-auto.diff
# Manually created patch for downstream crate metadata changes # Manually created patch for downstream crate metadata changes
# * drop +cargo version suffix from crate version # * drop +cargo version suffix from crate version
# * remove vendored OpenSSL feature # * remove vendored OpenSSL feature
Patch: cargo-c-fix-metadata.diff Patch: cargo-c-fix-metadata.diff
BuildRequires: rust-packaging >= 23 BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand: %global _description %{expand:
Helper program to build and install c-like libraries.} Helper program to build and install c-like libraries.}
@ -32,21 +32,25 @@ Helper program to build and install c-like libraries.}
%package -n %{crate} %package -n %{crate}
Summary: %{summary} Summary: %{summary}
# (Apache-2.0 OR MIT) AND BSD-3-Clause
# (MIT OR Apache-2.0) AND BSD-3-Clause AND GPL-2.0-only WITH GCC-exception-2.0 AND MIT # (MIT OR Apache-2.0) AND BSD-3-Clause AND GPL-2.0-only WITH GCC-exception-2.0 AND MIT
# (MIT OR Apache-2.0) AND Unicode-DFS-2016 # (MIT OR Apache-2.0) AND Unicode-DFS-2016
# 0BSD OR MIT OR Apache-2.0
# Apache-2.0 # Apache-2.0
# Apache-2.0 OR BSL-1.0 # Apache-2.0 OR BSL-1.0
# Apache-2.0 OR MIT # Apache-2.0 OR MIT
# Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT # Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
# BSD-3-Clause # BSD-3-Clause
# ISC
# MIT # MIT
# MIT OR Apache-2.0 # MIT OR Apache-2.0
# MIT OR Apache-2.0 OR BSD-1-Clause # MIT OR Apache-2.0 OR BSD-1-Clause
# MIT OR Apache-2.0 OR Zlib # MIT OR Apache-2.0 OR Zlib
# MIT OR Zlib OR Apache-2.0
# MPL-2.0 # MPL-2.0
# Unlicense OR MIT # Unlicense OR MIT
# Zlib OR Apache-2.0 OR MIT # Zlib OR Apache-2.0 OR MIT
License: Apache-2.0 AND BSD-3-Clause AND GPL-2.0-only WITH GCC-exception-2.0 AND MIT AND MPL-2.0 AND Unicode-DFS-2016 AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (MIT OR Apache-2.0 OR BSD-1-Clause) AND (MIT OR Apache-2.0 OR Zlib) AND (Unlicense OR MIT) License: MIT AND Apache-2.0 AND BSD-3-Clause AND GPL-2.0-only WITH GCC-exception-2.0 AND ISC AND MPL-2.0 AND Unicode-DFS-2016 AND (0BSD OR MIT OR Apache-2.0) AND (Apache-2.0 OR BSL-1.0) AND (Apache-2.0 OR MIT) AND (Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT) AND (MIT OR Apache-2.0 OR BSD-1-Clause) AND (MIT OR Apache-2.0 OR Zlib) AND (Unlicense OR MIT)
# LICENSE.dependencies contains a full license breakdown # LICENSE.dependencies contains a full license breakdown
%description -n %{crate} %{_description} %description -n %{crate} %{_description}
@ -96,7 +100,7 @@ use the "default" feature of the "%{crate}" crate.
%build %build
%cargo_build %cargo_build
%cargo_license_summary %{cargo_license_summary}
%{cargo_license} > LICENSE.dependencies %{cargo_license} > LICENSE.dependencies
%install %install

@ -1 +1 @@
SHA512 (cargo-c-0.9.19+cargo-0.70.crate) = 725b90f1723a2f1e23cf7d85abd8bb49a1916fb71aa20563415c06159f062a38669cdbbe4281040c78670b5116451513b5a11639dfa96015229cf8a85e8d9163 SHA512 (cargo-c-0.9.27+cargo-0.74.0.crate) = 013cbe2161d74c1d2a43f19b8621e9bfb68d8d533b383e98403826df83a15e685f96c28b34eac832295a6800710e54f67d524e2a5eacef56074b5ba0ce8f6f01

Loading…
Cancel
Save