Initial import (fedora#2228632).

epel10
Felix Maurer 1 year ago
parent a6f2f6901b
commit 81d9e9856e

1
.gitignore vendored

@ -0,0 +1 @@
/bzip2-rs-0.1.2.crate

@ -0,0 +1,21 @@
--- bzip2-rs-0.1.2/Cargo.toml 1970-01-01T00:00:00+00:00
+++ bzip2-rs-0.1.2/Cargo.toml 2023-08-03T22:10:01.718341+00:00
@@ -30,18 +30,12 @@
[dependencies.tinyvec]
version = "1.1"
-[dev-dependencies.bzip2]
-version = "0.4.1"
-
-[dev-dependencies.criterion]
-version = "0.3.4"
[dev-dependencies.pretty_assertions]
version = "0.6"
[features]
default = []
-nightly = ["rustc_1_40", "tinyvec/nightly_const_generics", "crc32fast/nightly"]
rustc_1_37 = []
rustc_1_40 = ["rustc_1_37", "tinyvec/rustc_1_40"]
rustc_1_51 = []

@ -0,0 +1,112 @@
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate bzip2-rs
Name: rust-bzip2-rs
Version: 0.1.2
Release: %autorelease
Summary: Pure Rust bzip2 decompressor
# Upstream license specification: MIT/Apache-2.0
License: MIT OR Apache-2.0
URL: https://crates.io/crates/bzip2-rs
Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# - remove dev-dependencies on criterion and bzip2 that are both only needed
# for benchmarks, which we don't run
# - remove the nightly feature, because the resulting rpm can not be installed
Patch: bzip2-rs-fix-metadata.diff
BuildRequires: rust-packaging >= 21
%global _description %{expand:
Pure Rust bzip2 decompressor.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc_1_37-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc_1_37-devel %{_description}
This package contains library source intended for building other packages which
use the "rustc_1_37" feature of the "%{crate}" crate.
%files -n %{name}+rustc_1_37-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc_1_40-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc_1_40-devel %{_description}
This package contains library source intended for building other packages which
use the "rustc_1_40" feature of the "%{crate}" crate.
%files -n %{name}+rustc_1_40-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+rustc_1_51-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+rustc_1_51-devel %{_description}
This package contains library source intended for building other packages which
use the "rustc_1_51" feature of the "%{crate}" crate.
%files -n %{name}+rustc_1_51-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif
%changelog
%autochangelog

@ -0,0 +1 @@
SHA512 (bzip2-rs-0.1.2.crate) = 00683e16f06a3c5589fbb6cb215ecccba4a8619916de80024a917f98f10bab4c663036fa3f922783ca19bb04a1653ec2ab593c1f36f587e931bd80cb11a79765
Loading…
Cancel
Save