commit
16731ef545
@ -0,0 +1 @@
|
||||
SOURCES/bzip2-rs-0.1.2.crate
|
@ -0,0 +1 @@
|
||||
4c394e71044cca98bbd3b56bb71cc8403b578e11 SOURCES/bzip2-rs-0.1.2.crate
|
@ -0,0 +1,39 @@
|
||||
From a13d0191d1f4bf8e8de34a5513e980ea8bf85e5c Mon Sep 17 00:00:00 2001
|
||||
From: rpm-build <rpm-build>
|
||||
Date: Mon, 28 Oct 2024 19:51:10 -0600
|
||||
Subject: [PATCH 2/2] Drop pretty_assertions removed upstream
|
||||
|
||||
---
|
||||
Cargo.toml | 3 ---
|
||||
tests/decode_reader.rs | 1 -
|
||||
2 files changed, 4 deletions(-)
|
||||
|
||||
diff --git a/Cargo.toml b/Cargo.toml
|
||||
index 9d06d0a..2b01f7a 100644
|
||||
--- a/Cargo.toml
|
||||
+++ b/Cargo.toml
|
||||
@@ -31,9 +31,6 @@ version = "1.2.1"
|
||||
[dependencies.tinyvec]
|
||||
version = "1.1"
|
||||
|
||||
-[dev-dependencies.pretty_assertions]
|
||||
-version = "0.6"
|
||||
-
|
||||
[features]
|
||||
default = []
|
||||
rustc_1_37 = []
|
||||
diff --git a/tests/decode_reader.rs b/tests/decode_reader.rs
|
||||
index a99cf30..5808718 100644
|
||||
--- a/tests/decode_reader.rs
|
||||
+++ b/tests/decode_reader.rs
|
||||
@@ -1,7 +1,6 @@
|
||||
use std::io::{self, Read};
|
||||
|
||||
use bzip2_rs::decoder::DecoderReader;
|
||||
-use pretty_assertions::assert_eq;
|
||||
|
||||
#[test]
|
||||
fn empty() {
|
||||
--
|
||||
2.47.0
|
||||
|
@ -0,0 +1,3 @@
|
||||
# rust-bzip2-rs
|
||||
|
||||
The rust-bzip2-rs package
|
@ -0,0 +1,21 @@
|
||||
--- bzip2-rs-0.1.2/Cargo.toml 1970-01-01T00:00:00+00:00
|
||||
+++ bzip2-rs-0.1.2/Cargo.toml 2023-08-03T22:10:01.718341+00:00
|
||||
@@ -30,18 +30,12 @@
|
||||
|
||||
[dependencies.tinyvec]
|
||||
version = "1.1"
|
||||
-[dev-dependencies.bzip2]
|
||||
-version = "0.4.1"
|
||||
-
|
||||
-[dev-dependencies.criterion]
|
||||
-version = "0.3.4"
|
||||
|
||||
[dev-dependencies.pretty_assertions]
|
||||
version = "0.6"
|
||||
|
||||
[features]
|
||||
default = []
|
||||
-nightly = ["rustc_1_40", "tinyvec/nightly_const_generics", "crc32fast/nightly"]
|
||||
rustc_1_37 = []
|
||||
rustc_1_40 = ["rustc_1_37", "tinyvec/rustc_1_40"]
|
||||
rustc_1_51 = []
|
@ -0,0 +1,137 @@
|
||||
## START: Set by rpmautospec
|
||||
## (rpmautospec version 0.7.3)
|
||||
## RPMAUTOSPEC: autorelease, autochangelog
|
||||
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
|
||||
release_number = 3;
|
||||
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||
print(release_number + base_release_number - 1);
|
||||
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
|
||||
## END: Set by rpmautospec
|
||||
|
||||
# Generated by rust2rpm 24
|
||||
%bcond_without check
|
||||
%global debug_package %{nil}
|
||||
|
||||
%global crate bzip2-rs
|
||||
|
||||
Name: rust-bzip2-rs
|
||||
Version: 0.1.2
|
||||
Release: %autorelease
|
||||
Summary: Pure Rust bzip2 decompressor
|
||||
|
||||
# Upstream license specification: MIT/Apache-2.0
|
||||
License: MIT OR Apache-2.0
|
||||
URL: https://crates.io/crates/bzip2-rs
|
||||
Source: %{crates_source}
|
||||
# Manually created patch for downstream crate metadata changes
|
||||
# - remove dev-dependencies on criterion and bzip2 that are both only needed
|
||||
# for benchmarks, which we don't run
|
||||
# - remove the nightly feature, because the resulting rpm can not be installed
|
||||
Patch: bzip2-rs-fix-metadata.diff
|
||||
# Upstream patch that drops pretty_assertions dependency
|
||||
# https://github.com/paolobarbolini/bzip2-rs/commit/d407c34f3e028ad6188a84b675c4cc3a632b2e06.
|
||||
Patch: 0002-Drop-pretty_assertions-removed-upstream.patch
|
||||
|
||||
BuildRequires: rust-packaging >= 21
|
||||
|
||||
%global _description %{expand:
|
||||
Pure Rust bzip2 decompressor.}
|
||||
|
||||
%description %{_description}
|
||||
|
||||
%package devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "%{crate}" crate.
|
||||
|
||||
%files devel
|
||||
%license %{crate_instdir}/LICENSE-APACHE
|
||||
%license %{crate_instdir}/LICENSE-MIT
|
||||
%doc %{crate_instdir}/CHANGELOG.md
|
||||
%doc %{crate_instdir}/README.md
|
||||
%{crate_instdir}/
|
||||
|
||||
%package -n %{name}+default-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+default-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "default" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+default-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustc_1_37-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustc_1_37-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustc_1_37" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustc_1_37-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustc_1_40-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustc_1_40-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustc_1_40" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustc_1_40-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%package -n %{name}+rustc_1_51-devel
|
||||
Summary: %{summary}
|
||||
BuildArch: noarch
|
||||
|
||||
%description -n %{name}+rustc_1_51-devel %{_description}
|
||||
|
||||
This package contains library source intended for building other packages which
|
||||
use the "rustc_1_51" feature of the "%{crate}" crate.
|
||||
|
||||
%files -n %{name}+rustc_1_51-devel
|
||||
%ghost %{crate_instdir}/Cargo.toml
|
||||
|
||||
%prep
|
||||
%autosetup -n %{crate}-%{version_no_tilde} -p1
|
||||
%cargo_prep
|
||||
|
||||
%generate_buildrequires
|
||||
%cargo_generate_buildrequires
|
||||
|
||||
%build
|
||||
%cargo_build
|
||||
|
||||
%install
|
||||
%cargo_install
|
||||
|
||||
%if %{with check}
|
||||
%check
|
||||
%cargo_test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Dec 20 2024 MSVSphere Packaging Team <packager@msvsphere-os.ru> - 0.1.2-3
|
||||
- Rebuilt for MSVSphere 10
|
||||
|
||||
## START: Generated by rpmautospec
|
||||
* Tue Oct 29 2024 Orion Poplawski <orion@nwra.com> - 0.1.2-3
|
||||
- Backport upstream patch to remove build dependency on pretty_assertions
|
||||
|
||||
* Fri Jul 19 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Thu Jan 25 2024 Felix Maurer <fmaurer@redhat.com> - 0.1.2-1
|
||||
- Initial import (fedora#2228632).
|
||||
## END: Generated by rpmautospec
|
Loading…
Reference in new issue