Update to version 1.3.2; Fixes RHBZ#2344782

epel10 imports/epel10/rust-bytesize-1.3.2-1.el10
Fabio Valentini 2 weeks ago
parent 3ce1864de2
commit 9716999504
No known key found for this signature in database
GPG Key ID: 5AC5F572E5D410AF

1
.gitignore vendored

@ -3,3 +3,4 @@
/bytesize-1.1.0.crate
/bytesize-1.2.0.crate
/bytesize-1.3.0.crate
/bytesize-1.3.2.crate

@ -1,28 +0,0 @@
From 566c1b27883ef1ee2d9708985cfe3651855c3954 Mon Sep 17 00:00:00 2001
From: Fabio Valentini <decathorpe@gmail.com>
Date: Thu, 8 Aug 2024 14:16:03 +0200
Subject: [PATCH] fix typo in doc code block annotation that caused test
failures
Since Rust 1.80, rustdoc seems to be more strict about which code block
annotations result in code blocks to be treated as non-Rust code.
---
src/lib.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/lib.rs b/src/lib.rs
index 01c4440..21ec699 100644
--- a/src/lib.rs
+++ b/src/lib.rs
@@ -22,7 +22,7 @@
//!
//! It also provides its human readable string as follows:
//!
-//! ```ignore=
+//! ```ignore
//! assert_eq!("482 GiB".to_string(), ByteSize::gb(518).to_string(true));
//! assert_eq!("518 GB".to_string(), ByteSize::gb(518).to_string(false));
//! ```
--
2.46.0

@ -1,11 +1,8 @@
--- bytesize-1.3.0/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bytesize-1.3.0/Cargo.toml 2024-09-21T11:28:23.094321+00:00
@@ -39,7 +39,7 @@
--- bytesize-1.3.2/Cargo.toml 1970-01-01T00:00:01+00:00
+++ bytesize-1.3.2/Cargo.toml 2025-02-14T13:59:26.538462+00:00
@@ -53,4 +53,4 @@
version = "1.0.105"
[dev-dependencies.toml]
-version = "0.7.6"
+version = "0.8"
[features]
default = []

@ -1,11 +1,11 @@
# Generated by rust2rpm 26
%bcond_without check
# Generated by rust2rpm 27
%bcond check 1
%global debug_package %{nil}
%global crate bytesize
Name: rust-bytesize
Version: 1.3.0
Version: 1.3.2
Release: %autorelease
Summary: Utility for human-readable bytes representations
@ -15,8 +15,6 @@ Source: %{crates_source}
# Manually created patch for downstream crate metadata changes
# * bump toml dev-dependency from 0.7 to 0.8
Patch: bytesize-fix-metadata.diff
# * patch to fix doctests with Rust 1.80+
Patch: 0001-fix-typo-in-doc-code-block-annotation-that-caused-te.patch
BuildRequires: cargo-rpm-macros >= 24

@ -1 +1 @@
SHA512 (bytesize-1.3.0.crate) = c718af51b0da2979b70142012544fde6bbf8639cd4fde66a8066b138f7f58dce019209e27566027dc0ec5a7fc1d2ee17b9b6366cc7a5f95a6419e29a0ffedab5
SHA512 (bytesize-1.3.2.crate) = 6c86f004f9c7c58233f8aa59fe731c84fbcacceacd3defc99362b1ba93d6df828bd8c41d028f44bad460a8d03862e742a04abb77f558d739ed08735f581ef2e7

Loading…
Cancel
Save