parent
9984d958d1
commit
a9b10b720b
@ -1 +1,2 @@
|
||||
/bpaf-0.9.13.crate
|
||||
/bpaf-0.9.15.crate
|
||||
|
@ -0,0 +1,25 @@
|
||||
From d912d22f5d0c6a430c78c2dff030f5ef5556aa15 Mon Sep 17 00:00:00 2001
|
||||
From: Fabio Valentini <decathorpe@gmail.com>
|
||||
Date: Wed, 23 Oct 2024 14:52:49 +0200
|
||||
Subject: [PATCH] use correct import statement to fix compilation of tests
|
||||
|
||||
---
|
||||
src/tests.rs | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/tests.rs b/src/tests.rs
|
||||
index ce7ef76..8dc85ab 100644
|
||||
--- a/src/tests.rs
|
||||
+++ b/src/tests.rs
|
||||
@@ -85,7 +85,7 @@ fn fallback_with_strange_args_produces_same_results() {
|
||||
|
||||
#[test]
|
||||
fn de_yoda() {
|
||||
- use bpaf::*;
|
||||
+ use crate::*;
|
||||
let parser = construct!(a(short('a').switch()), b(short('b').switch())).to_options();
|
||||
|
||||
let r = parser.run_inner(&[]).unwrap();
|
||||
--
|
||||
2.47.0
|
||||
|
@ -1,201 +0,0 @@
|
||||
Apache License
|
||||
Version 2.0, January 2004
|
||||
http://www.apache.org/licenses/
|
||||
|
||||
TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION
|
||||
|
||||
1. Definitions.
|
||||
|
||||
"License" shall mean the terms and conditions for use, reproduction,
|
||||
and distribution as defined by Sections 1 through 9 of this document.
|
||||
|
||||
"Licensor" shall mean the copyright owner or entity authorized by
|
||||
the copyright owner that is granting the License.
|
||||
|
||||
"Legal Entity" shall mean the union of the acting entity and all
|
||||
other entities that control, are controlled by, or are under common
|
||||
control with that entity. For the purposes of this definition,
|
||||
"control" means (i) the power, direct or indirect, to cause the
|
||||
direction or management of such entity, whether by contract or
|
||||
otherwise, or (ii) ownership of fifty percent (50%) or more of the
|
||||
outstanding shares, or (iii) beneficial ownership of such entity.
|
||||
|
||||
"You" (or "Your") shall mean an individual or Legal Entity
|
||||
exercising permissions granted by this License.
|
||||
|
||||
"Source" form shall mean the preferred form for making modifications,
|
||||
including but not limited to software source code, documentation
|
||||
source, and configuration files.
|
||||
|
||||
"Object" form shall mean any form resulting from mechanical
|
||||
transformation or translation of a Source form, including but
|
||||
not limited to compiled object code, generated documentation,
|
||||
and conversions to other media types.
|
||||
|
||||
"Work" shall mean the work of authorship, whether in Source or
|
||||
Object form, made available under the License, as indicated by a
|
||||
copyright notice that is included in or attached to the work
|
||||
(an example is provided in the Appendix below).
|
||||
|
||||
"Derivative Works" shall mean any work, whether in Source or Object
|
||||
form, that is based on (or derived from) the Work and for which the
|
||||
editorial revisions, annotations, elaborations, or other modifications
|
||||
represent, as a whole, an original work of authorship. For the purposes
|
||||
of this License, Derivative Works shall not include works that remain
|
||||
separable from, or merely link (or bind by name) to the interfaces of,
|
||||
the Work and Derivative Works thereof.
|
||||
|
||||
"Contribution" shall mean any work of authorship, including
|
||||
the original version of the Work and any modifications or additions
|
||||
to that Work or Derivative Works thereof, that is intentionally
|
||||
submitted to Licensor for inclusion in the Work by the copyright owner
|
||||
or by an individual or Legal Entity authorized to submit on behalf of
|
||||
the copyright owner. For the purposes of this definition, "submitted"
|
||||
means any form of electronic, verbal, or written communication sent
|
||||
to the Licensor or its representatives, including but not limited to
|
||||
communication on electronic mailing lists, source code control systems,
|
||||
and issue tracking systems that are managed by, or on behalf of, the
|
||||
Licensor for the purpose of discussing and improving the Work, but
|
||||
excluding communication that is conspicuously marked or otherwise
|
||||
designated in writing by the copyright owner as "Not a Contribution."
|
||||
|
||||
"Contributor" shall mean Licensor and any individual or Legal Entity
|
||||
on behalf of whom a Contribution has been received by Licensor and
|
||||
subsequently incorporated within the Work.
|
||||
|
||||
2. Grant of Copyright License. Subject to the terms and conditions of
|
||||
this License, each Contributor hereby grants to You a perpetual,
|
||||
worldwide, non-exclusive, no-charge, royalty-free, irrevocable
|
||||
copyright license to reproduce, prepare Derivative Works of,
|
||||
publicly display, publicly perform, sublicense, and distribute the
|
||||
Work and such Derivative Works in Source or Object form.
|
||||
|
||||
3. Grant of Patent License. Subject to the terms and conditions of
|
||||
this License, each Contributor hereby grants to You a perpetual,
|
||||
worldwide, non-exclusive, no-charge, royalty-free, irrevocable
|
||||
(except as stated in this section) patent license to make, have made,
|
||||
use, offer to sell, sell, import, and otherwise transfer the Work,
|
||||
where such license applies only to those patent claims licensable
|
||||
by such Contributor that are necessarily infringed by their
|
||||
Contribution(s) alone or by combination of their Contribution(s)
|
||||
with the Work to which such Contribution(s) was submitted. If You
|
||||
institute patent litigation against any entity (including a
|
||||
cross-claim or counterclaim in a lawsuit) alleging that the Work
|
||||
or a Contribution incorporated within the Work constitutes direct
|
||||
or contributory patent infringement, then any patent licenses
|
||||
granted to You under this License for that Work shall terminate
|
||||
as of the date such litigation is filed.
|
||||
|
||||
4. Redistribution. You may reproduce and distribute copies of the
|
||||
Work or Derivative Works thereof in any medium, with or without
|
||||
modifications, and in Source or Object form, provided that You
|
||||
meet the following conditions:
|
||||
|
||||
(a) You must give any other recipients of the Work or
|
||||
Derivative Works a copy of this License; and
|
||||
|
||||
(b) You must cause any modified files to carry prominent notices
|
||||
stating that You changed the files; and
|
||||
|
||||
(c) You must retain, in the Source form of any Derivative Works
|
||||
that You distribute, all copyright, patent, trademark, and
|
||||
attribution notices from the Source form of the Work,
|
||||
excluding those notices that do not pertain to any part of
|
||||
the Derivative Works; and
|
||||
|
||||
(d) If the Work includes a "NOTICE" text file as part of its
|
||||
distribution, then any Derivative Works that You distribute must
|
||||
include a readable copy of the attribution notices contained
|
||||
within such NOTICE file, excluding those notices that do not
|
||||
pertain to any part of the Derivative Works, in at least one
|
||||
of the following places: within a NOTICE text file distributed
|
||||
as part of the Derivative Works; within the Source form or
|
||||
documentation, if provided along with the Derivative Works; or,
|
||||
within a display generated by the Derivative Works, if and
|
||||
wherever such third-party notices normally appear. The contents
|
||||
of the NOTICE file are for informational purposes only and
|
||||
do not modify the License. You may add Your own attribution
|
||||
notices within Derivative Works that You distribute, alongside
|
||||
or as an addendum to the NOTICE text from the Work, provided
|
||||
that such additional attribution notices cannot be construed
|
||||
as modifying the License.
|
||||
|
||||
You may add Your own copyright statement to Your modifications and
|
||||
may provide additional or different license terms and conditions
|
||||
for use, reproduction, or distribution of Your modifications, or
|
||||
for any such Derivative Works as a whole, provided Your use,
|
||||
reproduction, and distribution of the Work otherwise complies with
|
||||
the conditions stated in this License.
|
||||
|
||||
5. Submission of Contributions. Unless You explicitly state otherwise,
|
||||
any Contribution intentionally submitted for inclusion in the Work
|
||||
by You to the Licensor shall be under the terms and conditions of
|
||||
this License, without any additional terms or conditions.
|
||||
Notwithstanding the above, nothing herein shall supersede or modify
|
||||
the terms of any separate license agreement you may have executed
|
||||
with Licensor regarding such Contributions.
|
||||
|
||||
6. Trademarks. This License does not grant permission to use the trade
|
||||
names, trademarks, service marks, or product names of the Licensor,
|
||||
except as required for reasonable and customary use in describing the
|
||||
origin of the Work and reproducing the content of the NOTICE file.
|
||||
|
||||
7. Disclaimer of Warranty. Unless required by applicable law or
|
||||
agreed to in writing, Licensor provides the Work (and each
|
||||
Contributor provides its Contributions) on an "AS IS" BASIS,
|
||||
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
|
||||
implied, including, without limitation, any warranties or conditions
|
||||
of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A
|
||||
PARTICULAR PURPOSE. You are solely responsible for determining the
|
||||
appropriateness of using or redistributing the Work and assume any
|
||||
risks associated with Your exercise of permissions under this License.
|
||||
|
||||
8. Limitation of Liability. In no event and under no legal theory,
|
||||
whether in tort (including negligence), contract, or otherwise,
|
||||
unless required by applicable law (such as deliberate and grossly
|
||||
negligent acts) or agreed to in writing, shall any Contributor be
|
||||
liable to You for damages, including any direct, indirect, special,
|
||||
incidental, or consequential damages of any character arising as a
|
||||
result of this License or out of the use or inability to use the
|
||||
Work (including but not limited to damages for loss of goodwill,
|
||||
work stoppage, computer failure or malfunction, or any and all
|
||||
other commercial damages or losses), even if such Contributor
|
||||
has been advised of the possibility of such damages.
|
||||
|
||||
9. Accepting Warranty or Additional Liability. While redistributing
|
||||
the Work or Derivative Works thereof, You may choose to offer,
|
||||
and charge a fee for, acceptance of support, warranty, indemnity,
|
||||
or other liability obligations and/or rights consistent with this
|
||||
License. However, in accepting such obligations, You may act only
|
||||
on Your own behalf and on Your sole responsibility, not on behalf
|
||||
of any other Contributor, and only if You agree to indemnify,
|
||||
defend, and hold each Contributor harmless for any liability
|
||||
incurred by, or claims asserted against, such Contributor by reason
|
||||
of your accepting any such warranty or additional liability.
|
||||
|
||||
END OF TERMS AND CONDITIONS
|
||||
|
||||
APPENDIX: How to apply the Apache License to your work.
|
||||
|
||||
To apply the Apache License to your work, attach the following
|
||||
boilerplate notice, with the fields enclosed by brackets "[]"
|
||||
replaced with your own identifying information. (Don't include
|
||||
the brackets!) The text should be enclosed in the appropriate
|
||||
comment syntax for the file format. We also recommend that a
|
||||
file or class name and description of purpose be included on the
|
||||
same "printed page" as the copyright notice for easier
|
||||
identification within third-party archives.
|
||||
|
||||
Copyright [yyyy] [name of copyright owner]
|
||||
|
||||
Licensed under the Apache License, Version 2.0 (the "License");
|
||||
you may not use this file except in compliance with the License.
|
||||
You may obtain a copy of the License at
|
||||
|
||||
http://www.apache.org/licenses/LICENSE-2.0
|
||||
|
||||
Unless required by applicable law or agreed to in writing, software
|
||||
distributed under the License is distributed on an "AS IS" BASIS,
|
||||
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
|
||||
See the License for the specific language governing permissions and
|
||||
limitations under the License.
|
@ -1,23 +0,0 @@
|
||||
Permission is hereby granted, free of charge, to any
|
||||
person obtaining a copy of this software and associated
|
||||
documentation files (the "Software"), to deal in the
|
||||
Software without restriction, including without
|
||||
limitation the rights to use, copy, modify, merge,
|
||||
publish, distribute, sublicense, and/or sell copies of
|
||||
the Software, and to permit persons to whom the Software
|
||||
is furnished to do so, subject to the following
|
||||
conditions:
|
||||
|
||||
The above copyright notice and this permission notice
|
||||
shall be included in all copies or substantial portions
|
||||
of the Software.
|
||||
|
||||
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF
|
||||
ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
|
||||
TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
|
||||
PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT
|
||||
SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY
|
||||
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
|
||||
OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR
|
||||
IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
|
||||
DEALINGS IN THE SOFTWARE.
|
@ -1,194 +0,0 @@
|
||||
--- bpaf-0.9.13/Cargo.toml 1970-01-01T00:00:01+00:00
|
||||
+++ bpaf-0.9.13/Cargo.toml 2024-09-12T16:48:36.941444+00:00
|
||||
@@ -19,6 +19,8 @@
|
||||
include = [
|
||||
"src/**/*",
|
||||
"Cargo.toml",
|
||||
+ "LICENSE-APACHE",
|
||||
+ "LICENSE-MIT",
|
||||
"README.md",
|
||||
"examples/**/*",
|
||||
]
|
||||
@@ -55,182 +57,6 @@
|
||||
name = "bpaf"
|
||||
path = "src/lib.rs"
|
||||
|
||||
-[[example]]
|
||||
-name = "at_least_two"
|
||||
-path = "examples/at_least_two.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "basic"
|
||||
-path = "examples/basic.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "cargo-cmd"
|
||||
-path = "examples/cargo-cmd.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "cat"
|
||||
-path = "examples/cat.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "compression"
|
||||
-path = "examples/compression.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "confusing"
|
||||
-path = "examples/confusing.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "coreutils"
|
||||
-path = "examples/coreutils.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "csample"
|
||||
-path = "examples/csample.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "customize_help"
|
||||
-path = "examples/customize_help.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "dd"
|
||||
-path = "examples/dd.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "derive"
|
||||
-path = "examples/derive.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "derive-smart-pointer"
|
||||
-path = "examples/derive-smart-pointer.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "derive_commands"
|
||||
-path = "examples/derive_commands.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "derive_rudo"
|
||||
-path = "examples/derive_rudo.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "derive_show_asm"
|
||||
-path = "examples/derive_show_asm.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "derive_this_or_that"
|
||||
-path = "examples/derive_this_or_that.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "dynamic"
|
||||
-path = "examples/dynamic.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "dynamic-tree"
|
||||
-path = "examples/dynamic-tree.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "enum_in_args"
|
||||
-path = "examples/enum_in_args.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "enum_tuple"
|
||||
-path = "examples/enum_tuple.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "env_logger"
|
||||
-path = "examples/env_logger.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "env_variable"
|
||||
-path = "examples/env_variable.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "ex_positional"
|
||||
-path = "examples/ex_positional.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "fallback_command"
|
||||
-path = "examples/fallback_command.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "filenames"
|
||||
-path = "examples/filenames.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "find"
|
||||
-path = "examples/find.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "flatten"
|
||||
-path = "examples/flatten.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "git"
|
||||
-path = "examples/git.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "many_comma_separated_args"
|
||||
-path = "examples/many_comma_separated_args.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "many_comma_separated_args_derive"
|
||||
-path = "examples/many_comma_separated_args_derive.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "multiple_fallback"
|
||||
-path = "examples/multiple_fallback.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "negative"
|
||||
-path = "examples/negative.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "no_import"
|
||||
-path = "examples/no_import.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "numeric_prefix"
|
||||
-path = "examples/numeric_prefix.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "positional_derive"
|
||||
-path = "examples/positional_derive.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "rectangle"
|
||||
-path = "examples/rectangle.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "sensors"
|
||||
-path = "examples/sensors.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "shared_args"
|
||||
-path = "examples/shared_args.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "simple_dynamic"
|
||||
-path = "examples/simple_dynamic.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "top_to_bottom"
|
||||
-path = "examples/top_to_bottom.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "travel"
|
||||
-path = "examples/travel.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "verbose"
|
||||
-path = "examples/verbose.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "very_custom_usage"
|
||||
-path = "examples/very_custom_usage.rs"
|
||||
-
|
||||
-[[example]]
|
||||
-name = "xorg"
|
||||
-path = "examples/xorg.rs"
|
||||
-
|
||||
[dependencies.bpaf_derive]
|
||||
version = "=0.5.13"
|
||||
optional = true
|
@ -1,18 +1,8 @@
|
||||
[package]
|
||||
cargo-toml-patch-comments = [
|
||||
"Drop examples as they fail to build",
|
||||
"Include license files",
|
||||
]
|
||||
extra-sources = [
|
||||
{ "number" = 2, "file" = "https://github.com/pacak/bpaf/raw/dd8e2772b7f6e17ffbcdcfdda1e55776615e25e0/LICENSE-APACHE", "comments" = ["https://github.com/pacak/bpaf/pull/388"] },
|
||||
{ "number" = 3, "file" = "https://github.com/pacak/bpaf/raw/dd8e2772b7f6e17ffbcdcfdda1e55776615e25e0/LICENSE-MIT", "comments" = ["https://github.com/pacak/bpaf/pull/388"] },
|
||||
]
|
||||
|
||||
[scripts]
|
||||
prep.pre = [
|
||||
"cp -p %SOURCE2 %SOURCE3 ."
|
||||
]
|
||||
[features]
|
||||
enable = ["autocomplete", "derive"]
|
||||
|
||||
[tests]
|
||||
comments = ["Tests fail to build"]
|
||||
run = ["none"]
|
||||
skip = ["buffer::splitter::ticks_code_block"]
|
||||
skip-exact = true
|
||||
comments = ["skip one test that fails for yet unknown reasons"]
|
||||
|
||||
|
@ -1 +1 @@
|
||||
SHA512 (bpaf-0.9.13.crate) = d9d68f686ac0a8b12e07429b2fb42f2724c7c0605b25e7cbc8aa173c0d28e37478fa0a830c621a50017604a1399c9ba38d0f934bf3f4fd2bf2dc51c5f1bb6290
|
||||
SHA512 (bpaf-0.9.15.crate) = 4b7d0e7d72aca28683ef5c0bfeea337673e1066aa58d2df8b72a95a55ffcfbd976d93211fc782789971e3688ffe579a8460c827e525872eed85263cd861caa82
|
||||
|
Loading…
Reference in new issue